1

I have the OpenXML SDK installed on my development machine, and I have written a webpart solution that basically creates an excel file using the OpenXML dll. This solution is a full farm solution not a Sandbox solution.

When I deployed on my PC all is ok, as I have the OpenXML SDK installed, and all the revent dll's required for my webpart is in place on my PC. However when I deploy my WSP to the live server, it doesn't have the SDK installed.

How do I ensure the OpenXML dlls are available on the live farm without having to install the OpenXML SDK on each server in the live farm. There must be something I can do within my solution to ensure the dlls are available.

Regards

Paul.

1

Your issue is that the openxml dll is not being deployed on the machine global assembly cache. Make sure your package is configured correctly. enter image description here

  • Thanks Jaime, I kept looking at that screen, but wasn't sure. Should have just given it a go. – Cann0nF0dder Sep 14 '12 at 10:19
  • No worries. Just remember any external dll should be packaged too. Happy coding – Jaime Sep 15 '12 at 16:17
0

I'm not familiar with OpenXML. But if it's this package: NuGet - DocumentFormat.OpenXml you could first run:

Install-Package DocumentFormat.OpenXml

And then reference the DLL files in your package.
You will find the DLL files on solution level under Packages

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.