We are still in the process of rolling out SharePoint, but we’ve got the server up and running and the primary site is working. We set it up as sharepoint.mydomain.com. I then created a new site called ‘Help Center’ and it’s URL was sharepoint.mydomain.com/help_center. After adding a bunch of content, and starting to plan to roll it out we decided to change the URL to sharepoint.crowholdings.com/help (just because we are picky like that). I did this by going to the site (at the original URL), going to Site Settings>Title, Description, and Icon, and in the URL name box I changed ‘help_center’ to ‘help’ and clicked OK. That’s when all hell broke loose. I got an error, and unfortunately I did-not capture it before moving on so I don’t remember exactly what it said – but I noticed that in the address bar it was still showing the old URL (/help_center/) so I tried changing it to the new URL (/help/) but then I got a 404 error. I tried IISReset, and even rebooted the server – but I still get a 404 error every time I try to access the page. Back on my primary site, the URL on the Help Center tab has been updated to the new URL (sharepoint.mydomain.com/help/SitePages/Home.aspx), but when I click it I just get the 404 error. I can’t access the site with the new URL or the old URL.

I can still see the site and all of it's assets in the site manager, but I still get the 404 error when I try to access any of the site settings from the menu (site settings, people and groups, advanced permissions, or general settings). If I try changing the URL in the address bar from the new name to the old name, i get a different error that just says 'file not found'.

I also tried using the stsadm commands (referenced here: http://technet.microsoft.com/en-us/library/cc263508.aspx), but I get the following errors:

  • When I try using the NEW name, I get the error: The site sharepoint.mydomain.com/help could not be found in the Web application SPWebApplication Name=sharepoint.mydomain.com.
  • When I try using the OLD name, I get the error: 0x80070002There is no Web named "/help_center".

In SharePoint Designer, I can connect to sharepoint.mydomain.com, and I can SEE the sub-site called 'Help Center' (it shows the URL /help/), but when I try to connect to it I get this: Server error:

The URL "sharepoint.mydomain.com/help/_vti_bin/_vti_aut/author.dll"; is not contained within a Microsoft SharePoint Foundation site.

When I try to run the PowerShell cmdlets provided in my original post, I can't get past the first line before I get this error (same error when I use the old and new URL):

Get-SPWeb : Cannot find an SPSite object that contains the following Id or Url: sharepoint.mydomain.com/help. At line:1 char:18 + $help = get-spweb <<<< sharepoint.mydomain.com/help + CategoryInfo : InvalidData: (Microsoft.Share....SPCmdletGetWeb: SPCmdletGetWeb) [Get-SPWeb], SPCmdletPipeBindException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletGetWeb

'get-spweb without parameters' gives me an error that I need to provide a full URL or spsite object. When I run get-spweb http://sharepoint.mydomain.com it just comes back with sharepoint.mydomain.com under URL. When I run get-spsite, I get a list that mainly contains root sites (we have a few for our AX/CRM environment), and then I do see sharepoint.mydomain.com/sites/DMS which is another sub-site I created - but I do-not see the Help Center site listed.

I found this script on another thread (the one referenced at the bottom of my original post), and it returns a list that includes one titled 'Help Center' with the URL /help:

$site = Get-SPSite "http://sharepoint.mydomain.com" foreach ($web in $site.AllWebs) { $web | Select-Object -Property Title,Url | format-table -auto }

Any other suggetions would be greatly appreciated! Thanks! ][Q][

Original post: https://stackoverflow.com/questions/12359661/sharepoint-2010-404-error-after-renaming-subsite Similar post: https://stackoverflow.com/questions/1673678/sharepoint-404-error-after-renaming-subsite/12358909#12358909

  • Aha! I finally found a solution, although I'm still unsure what the problem was. I used SharePoint Manager 2010 [spm.codeplex.com/releases/view/51438] to change the 'ServerRelativeUrl' in the properties back to '/help_center' and now the site works again! I'm not even going to bother trying to change it back - don't feel like messing with it anymore... Sep 11, 2012 at 17:20
  • You don't happen to have a managed path or site collection identified in central admin at /help do you? Sep 11, 2012 at 20:06
  • Actually, yes there is a managed path in my web application called 'help'. is this a default? if-so, i think it's strange that SP would even allow me to change a site URL name to 'help'. here's what I'm seeing: help - Explicit inclusion Sep 13, 2012 at 16:33

1 Answer 1


You can't have a sub site at the location of a managed path as managed paths help define the root of a site collection.

Help is not a default SharePoint 2010 managed path out of the box. You can check if a site collection exists at that location by navigating to:

Application Management -> View all site collections -> Go through each web app and check for any site collections at /help (switch web apps from the upper right drop down menu)

If a site collection at /help does not exist and you are fairly certain it is not going to be used or is already needed by a feature or third party solution solution later down the road you should be able to safely remove the /help managed path.

  • And what if the site collection did exist, and he just wanted to access such a site at /help? I had to create an SC at a managed path off of the root site because that's the only way you can have your URL be somesite.com/xxxx instead of somesite.com/sites/xxxx. And I had to make it Wildcard inclusion. To run a script I had to revert to Explicit inclusion. My SC was then unavailable. I flipped back to Wildcard, but got another error. I removed the path, nothing was available. Added path with Explicit, site restored, SC was not. Flipped to Wildcard, SC available, root was not.
    – vapcguy
    Apr 5, 2019 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.