I receive "Access denied." "you do not have permission to perform this action or access this resource" after about 2 seconds when I attempt to "add" any custom .wsp web parts to a page. I am using SharePoint 2010 Enterprise. The site is hosted by a 3rd party on a shared sandboxed server. It is not O365 or SharePoint Online.

  • I am trying to add it logged in as the administrator but I have also tried logged in as another "Owner" user
  • My "Solution resource quota" is 1000, so that should not be the issue
  • The permissions for these web parts appear to be fine – inherited from parent site
  • I don’t see where else I may be able to change permissions for custom .wsp solutions, but I could easily be missing something?
  • I’ve tried on multiple pages, including the home page
  • I’ve tried installing and adding a 3rd party .wsp solutions and have the same issue so I don’t think my .wsp’s are causing the issue
  • The .wsp web parts are “active” in ”Site Collection Administration” > “Features”
  • I’ve done a bit of searching but don’t see any obvious solutions
  • This site collection has "anonymous access" enabled, but I've also tried adding the .wsp to page that don't have "anonymous access" turned on

What could I or the hoster tech support look into to resolve the "access denied" issue?

  • not sure, but can you briefly tell what that webpart does? e.g some database/file system access etc. Sep 8, 2012 at 8:30
  • Troubleshooting 3rd party solutions is always tricky, especially when you haven't written it and dont' have the source code. As a note to others, please post the full installation instructions that come with the solution, and let us know that you have followed them. It is highly likely that you will need to contact the 3rd party's technical support to resolve any issues.
    – James Love
    Sep 9, 2012 at 9:13

1 Answer 1


The issue is resolved, but I don't know why. The custom web parts are now working fine. I did nothing that would have fixed it. I know the server Control Panel software was new, so perhaps they fixed some bug. Or perhaps overnight the system reset/restarted something that resolved the issue. So the issue is fixed, but I can't explain what was wrong or how it got resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.