0

All the default content types are being hidden in our sites how to get them visible on all our sites.We are having SharePoint 2010 and i could see all the content types visible when I open the site through designer.Please any suggestions.Thanks in advance.

2
  • Any idea how it happened? That might provide a clue as to where to look for answers. Sep 6 '12 at 17:13
  • I have merged your questions. In future, please don't post a duplicate or near duplicate question - just edit the original one. Thanks.
    – SPDoctor
    Sep 6 '12 at 23:04
1

You can try to modify Hidden property of SPContenType, like

       SPContentType contentType = list.ContentTypes["Name"];
       if (!contentType.ReadOnly && !contentType.Sealed)
       {                
            contentType.Hidden = false;
            contentType.Update();

        }
0

Check the features that are enabled on the site and Site Collection as it is likely that one of the features you are expecting (like Publishing) has been disabled.

5
  • Hi dave publishing feature is on ...any other suggestions please!
    – vikky2266
    Sep 6 '12 at 18:08
  • Exactly which content types are missing?
    – Dave Wise
    Sep 6 '12 at 18:46
  • We are missing the default content types and when i try to activate the publishing feature it is giving me error "The parent content type specified by content type identifier 0x0101 does not exist." .
    – vikky2266
    Sep 6 '12 at 20:00
  • The publishing feature as mentioned by me earlier was activated I deactivated it and when i try to activate it again it gave me this error..
    – vikky2266
    Sep 6 '12 at 20:01
  • 0x0101 is the Document content type that is included in the hidden 'CTypes' feature, which is part of the very core of SharePoint. SharePoint will not allow a content type to be deleted if it is still in use so it is unlikely that this was simply turned off. My guess is that something drastic happened on your cloud provider, like the /FEATURES/ctypes folder somehow got zapped. You should involve their support team to help you work through this.
    – Dave Wise
    Sep 6 '12 at 20:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.