I have sharepoint 2010 installed on my local box for evaluation pourpouses. I had it all working fine until a few days ago when I had to change my AD password. Now, the central administration website is working but the other websites are not.

I've very new to sharepoint so I found out that there is a thing called manage accounts, where I had my user AD\MyName and it is responsible for most of the services on the website. I tried to update the password there as well, but after I click OK, the website just shows a "processing" message for a very long time. I also tried to chnge it using this scritp:

$password = Read-Host -AsSecureString
Set-SPManagedAccount -Identity "AD\MyName" -Password $password

no luck, I got a message saying that the password does not meet the password policy requirements, and I cant change it because I asusme the passowrd must be the same of my ad password

Also if I try any other tasks like creating a new web application for example, I also get a procesing message for several minutes and no resul, not even an error.

The logs at C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\LOGS are full of messages like this:

Exception occured while connecting to WCF endpoint: System.ServiceModel.Security.SecurityAccessDeniedException: Access is denied. Server stack trace: at System.ServiceModel.Channels.ServiceChannel.ThrowIfFaultUnderstood(Message reply, MessageFault fault, String action, MessageVersion version, FaultConverter faultConverter) at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc) at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout) at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation) at System.ServiceModel.Channels.ServiceChannelProxy... 18825743-f02b-4b45-a692-07075d49addc

so I see an acces denied message but I dont know what it is trying to access and using which permissions.

Everything I did here was "running as administrator"

Any one can help me please?

  • What is using this managed account?
    – mhijazi
    Sep 6, 2012 at 12:57
  • be sure to change SSRS "Unattended Execution Account" via SSRS configuration panel
    – Iman
    Dec 13, 2013 at 7:34

3 Answers 3


There is an easy way to get rid of this issue. If you have updated your farm administrator or local machine user password then you must update all SharePoint pools User passwords in IIS.

  • Go to IIS (run as administrator)
  • Click over application pools Select all those pools one by one containing particular user name and reset it then by clicking on advance setting.

  • After updating user names/passwords restart IIS (open CMD as administrator write iisreset or from wizard restart it).

Enjoy SharePoint once again. Best of luck.


Managed accounts are 'managed' by SharePoint. SharePoint can even change the password in AD automatically. (so don't use your own login or you might get locked out!!!). In your case the password stored by the 'SharePoint managed account' and the (new) real password are probably out of sync.

  • Check if the IIS 'application pool' users are set correctly to the new password.
  • Check if the user still has permissions to access the SharePoint databases
  • Check if the password of the SharePoint timer job is correct (= a Windows Service)
  • Check if the user can still access the SharePoint databases
  • Temporarily set the account as a site administrator
  • In Central Admin check if there are SharePoint services that use the AD account and enter the correct password again. ...

This post might also be helpful:



I have also faced same problem. Here is my solution:

  1. Go to IIS
  2. Click on Application pool
  3. Select "SharePoint Central Administrator V4"
  4. Go to the advance setting
  5. Click on Identity
  6. Within "custom account" select "set"
  7. Give your new password
  8. After that restart IIS
  • This is exaclty what Wassem wrote back in June, here below... Mar 20, 2014 at 8:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.