I'm trying to connect SP 2013 and TF 2012 and I am getting this message:

Reconnecting SharePoint Web application at the following address: http://mydomain.com:28940/. [Warning] TF205018: An error occurred when attempting to save the mapping from the SharePoint Web application to Team Foundation Server. The SharePoint Web application is: http://mydomain.com:28940/. The error is: TF250067: No connection could be made to Team Foundation Server at the following address: http://mydomain.com:8080/tfs. Either the specified URL does not point to a server that is running Team Foundation Server, the server is not available, or the service account for SharePoint Products does not have sufficient permissions on that server. The service account for SharePoint Products might not have been added to the required group in Team Foundation Server. For more information, see the Microsoft Web site (http://go.microsoft.com/fwlink/?LinkId=254457).. Reconnect operation failed with warnings and/or errors

As far as I can tell, the only account SP 2013 is using is a AD Administrator account, and I have that added as a TFS 2012 admin.

does anyone have any ideas?

1 Answer 1


This error message indicates that the SharePoint service account (the one that the IIS application pool is configured with) cannot be authenticated by TFS.

The SharePoint service accounts (for your SharePoint web applications that are running Central Admin, and any content web applications) need to a member of the "Service Accounts for SharePoint Web Applications" group. You can find this group in the TFS Management Console under the "SharePoint Web Applications" node.

If you need more details about which service account was being used, then you can check in the SharePoint log files for a message like "Unable to connect to Team Foundation Server at {0} as user {1}. The error is: {2}".

If you're not seeing any TFS related messages in the SharePoint log files ensure that the legacy trace providers have been enabled (run the following the SharePoint Management Shell > Set-SPDiagnosticConfig -AllowLegacyTraceProviders) and reset IIS before trying again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.