0

I have a list with few views. I've updated one view. Made column to be bold in the list's view. Then I opened a web part page and added this list (Page Tools -> Insert -> Existing Lists) then opened Web Part settings and selected customized view as 'Selected View'. After appying this change nothing happened. The text in this column is not bold in the web part. But it's bold on the list page.

Does it work as designed? So custom xslt for List's view works only for lists but not for XLV web parts?

0

If you do these changes in SharePoint designer, your changes are included in a web part markup on the view page. Thus if you use a view in SLV you will not be able to see these changes (it use diferent web part). You should create your XSL file, deploy it to the style library and add reference to this file into web part properties (Miscellaneous -> XSL Link).

3
  • Many thanks! And can I find existing XSL template for the web part somehow? So I could use it as an example.
    – Serhiy
    Sep 4 '12 at 8:59
  • I think that you can open the page that you made in SharePoint designer and coppy markup from xsl tag (I do not remember the correct name). The second approach is to see the main.xsl in the 14 folder.
    – Alexander
    Sep 4 '12 at 9:24
  • Thanks! By the way, in sharepoint designer the tag with XSL appears only after editing.
    – Serhiy
    Sep 4 '12 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.