I'm running into an issue with workflow emails that have whitespaces included in between each bullet point and I was wondering how I can remove them.

Here is my setup:

I have a SharePoint list that contains a field that stores email body content to be used in a workflow email. The field type that stores the email body content is a multiline text type that support full rich text editing. This field is an OOTB field type, not a custom field type. The email body content contains links and bullet points as well.

I have a SharePoint Designer 2010 list workflow that has an email action. Inside of this email, in the email body, I'm pulling the email body content from the sharepoint list that I mention in step 1 into the email body of the workflow email action. I'm pulling it in as a string instead of plain text.

The problem is that when the email is delivered to a customer, the bullet points have whitespaces between each point. After reviewing the html code it look like sharepoint tries to add span tags and br tags as well. What I need is to remove any un wanted whitespace from my email. I remember in SharePoint Designer 2007 you had an option to remove the whitespace from an email body.

Please help and thank you in advance.

  • I'm having this issue right now. :( – Dinerdo Aug 6 '15 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.