0

I am trying change the order of the Global Navigation in SharePoint 2010. I notice that the current site is the fixed even though in Navigation under "Global Navigation", there is nothing. I am trying to add a new item, the root site, and have that be first.

1 Answer 1

1

If i'm not wrong, the default SharePoint navigation use 2 levels menu. It means that if you would like to use root site as a start point, you will have the same menu as in parent site. if this is true for you, you can simply activate publishing features. After activation you can find out that the Look and Feel section contains Navigation option. If you click on this link you will be redirected to the page where you can customize navigation. Also you can set navigation inheritance from parent site.

enter image description here

4
  • I have publishing feature enabled but my problem is that in my subsite the first menu item is the current site and whatever link I add in Global Navigation, the current site is always first. I would like to change that order but am unable under Navigation because the current site link does not appear.
    – Rick
    Commented Sep 4, 2012 at 12:47
  • I updated my answer. As can you see I use display the same navigation items as the parent site option in subsite. Does it solve your problem or I miss something?
    – Alexander
    Commented Sep 4, 2012 at 13:51
  • Thanks, but I can't inherit the navigation, because my subsite's navigation is diferent on purpose. I just want the order to appear as Home | subsite, per your example. All I have been able to do is subsite | Home | OtherLink
    – Rick
    Commented Sep 4, 2012 at 18:44
  • In this case you should configure navigation by hand. In the Global Navigation section choose Display the navigation items below the current site, then in the Navigation Editing and Sorting section you should choose Global Navigation folder in the right size of the page and use Add Heading button. If you have a lot of sites that should be customized, you can use PowerShell or create your own feature.
    – Alexander
    Commented Sep 5, 2012 at 6:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.