I have deployed a solution to my farm and activated the feature.
I then navigate to:


I can see the webpart but I can't see it in:


What do I need to do to make the part show up in one of the sites?

  • Is it scoped at the Web level or the Site Collection level? Aug 28, 2012 at 17:29
  • I don't know the scope. How do I check?
    – Pasha
    Aug 28, 2012 at 17:37
  • I never heard webpart scopes ? scopes are only for features
    – tereško
    Aug 28, 2012 at 20:13
  • Exactly. First line of OP: "I deployed a solution to my farm, and activated the feature." Not all web parts will work at all scopes. What if the web part requires it be in a specific location in your site hierarchy? Aug 28, 2012 at 20:16

4 Answers 4


I may be offbase, but I can't help but noticing you activated the feature (a site collection or site feature) in sharepoint/ (that is, the root site collection), but you are trying to use it in sharepoint/sites/SITE which is a different site collection from the root site collection.

See if the feature is here this site collection (either as a site collection feature or a site feature) and activate it. The web part should then be available.

  • Features that contain web parts MUST be site collection features, or they do not appear in the Web Part Gallery. They also can't be added to a page. You are correct, the OP must activate the feature under Site Settings in the child site collection.
    – CigarDoug
    Jan 21, 2013 at 15:57

You can activate the feature in the Site Settings (Of the site in question) or use powershell:

enable-spfeature [Feature Name] -url "sharepoint/sites/[SITE]"
  • This shows up under farm solutions, not farm features. So, I get an error when I run that command.
    – Pasha
    Aug 28, 2012 at 18:40
  • Alright, run get-spsolution [name of wsp file] | %{ $sol = $_.SolutionId; get-spfeature | ?{$_.SolutionId -eq $sol} } This will tell what features were added by the solution and at what scope. Aug 29, 2012 at 15:37
  • After that you can run get-spsolution [name of wsp file] | %{ $sol = $_.SolutionId; get-spfeature | ?{$_.SolutionId -eq $sol} } | enable-spfeature -url [web url] Aug 29, 2012 at 15:38
  • Of course if it is a site scope feature then use the site url Aug 29, 2012 at 15:38

Did you populated webpart to gallery yet ?

you might like to check this post out , hope it helped ;)


A solution with a Web Part contains of several parts:
- A dll with the code for the web part
- A SafeControl entry
- A .webpart file with configuration for the web part
- A feature with a module element for the .webpart file

When you deploy the solution the following happens:
- The dll is installed in the GAC
- The SafeControl entry is added to web.config of the webapplication to which you deploy
This makes the Web Part usable in all Site Collections/Sites in the webapplication, but will not make it possible to add it to pages easily as it's not in the Web Part Gallary

To add the Web Part to the Gallary you need to activate the Feature on all site collections where you need it. This can be done:
- Manually
- Thought code
- In PowerShell
When added to the Web Part Gallary of the Site Collection it'll show up on all sites in that site Collection (But http://sharepoint/sites/[SITE] is not a site in http://sharepoint but a seperate Site Collection).

If you have a lot of Site Collections and want to have an "easy" way of adding webparts to all of them you might want to look at implementing a WebPartAdder see WebPartAdderExtension – a better way of deploying web parts

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.