A while back, I routinely applied a bunch of updates to our Sharepoint server (SBS 2003 / WSS 3). One of these seems to have put the sharepoint installation into a bad state - I could still access Central Admin, but the Web App was giving "Could not connect to the configuration database".

I tried to roll back the upgrade which related to the problem () but it seems to be irreversible. So after a few more hours of trying suggestions in forums, I had messed it up even further, and now Central Admin was also inaccessible, with the same error.

Weeks later, I finally have time to attempt a fix. I have a full set of backups from before the incident and I have been trying to restore them. I have the content and configuration databases, the 12 hive, and all the 3rd party templates and web parts that were installed first time round.

I setup a Windows Server 2008 VM as a restoration sandbox, installed WSS 3, created a web app with the same port number and https settings as the production server. I then deleted the default content database.

I then connected SSMS to the Windows Internal Database (SSEE) and attached the content database from the backup. Next, I used stsadm to restore the backed up content db:

stsadm -o addcontentdb -url http://myvm:555 -databasename WSS_Content

But this gave me:

The specified SPContentDatabase Name=WSS_Content Parent=SPDatabaseServiceInstanc
e Name=Microsoft##SSEE has been upgraded to a newer version of SharePoint. Pleas
e upgrade this SharePoint application server before attempting to access this ob

So naturally I tried to upgrade it:

stsadm -o upgrade -inplace -url http://myvm:555 -forceupgrade

When I attempt to add the content db again, I get the same error. There are no content databases listed in Central Admin. I'm stumped.

What can I try?

1 Answer 1


You need to bring your new SharePoint environment up to at least the same patch level as the one that failed. An easy solution would be to apply the latest Service Pack and possibly the latest Cumulative Update to the new farm. Once that is done, you should be able to attach the old content database and it should upgrade as part of the attach.

  • I will. I realised I forgot to say which patch it was that caused the error in the first place. Once I've looked through my logs, I will edit my question with it. Hopefully that will make it easier to answer. Aug 27, 2012 at 21:38
  • The new environment is version I'm sure this is the latest one as I only downloaded it today. Aug 27, 2012 at 21:46
  • That version is actually quite old (SP2, April 2009) and, according to the history is missing Service Pack 3 as well as the June 2012 Cumulative Update.
    – Dave Wise
    Aug 27, 2012 at 22:02
  • Ok, just installed WSS3 SP3, and successfully added content db (yay). But now get Error: Access Denied when opening web app. The production site was under an AD domain, but my VM is standalone. Is this going to be a show stopper? Aug 27, 2012 at 22:39
  • You will need to go into Central Administration and add whatever user account you are using on your local machine as a Site Collection Administrator for the site you just attached
    – Dave Wise
    Aug 28, 2012 at 13:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.