I have this very very weird thing happen in the SharePoint site.

Okay this is my situation:

I have this problem in one of the newly migrated site in the company. One of the user tries to "edit the properties" in the document list and after the user changed the properties and saved the change. The information in the list did not get update. But the version history showed the user did modify the document list. Only some of the documents in this "Document List" were like this.

I downloaded the affected PowerPoint from the SharePoint and changed the name and uploaded it to SharePoint site again, all the fields in the document list were automatically filled out for me and I saved the upload. Then I tried to changed the properties in the newly uploaded file, it will do the same thing (cannot update the save). However, if I tried to upload a dummy PowerPoint or delete all the custom metadata behind the PowerPoint and fill out the same information as before (this times the fields in the document list are all blank). Only then, I can modify the "list properties" successfully.

I gave them a workaround while I research on the problem and try to find a resolution. I asked them to check the file out and change the properties from within PowerPoint 2010 or 2007's File Property Page. This way the list property will get updated.

I'm wondering if anyone faced the same problems as I do and is there any way to solve this kind of problems. It seems to me the file is corrupted. I'm incline to ask the user to re-save the file again because the user that are using this site are not that great with technology. The users did not like my work around. They said it's too complicated for them.

  • I have the same problem with a PowerPoint file, did you find a solution? My opinion is that the file is corupt, I tried with a dummy file and is working, but not with a specific file. Regards, Octavian – user10520 Sep 4 '12 at 10:14
  • @Octavian I think I found the solution to the problem. I delete all the metadata behind the document and refill out the list information for that document in SP. I tried it many times in the test environment and so far I'm not able to break it. This is what I did to test it: I modified the properties at least 10 times and save it to another document name and change the information in the document list and redo all the steps for the new document name. I'm crossing my finger and hope after I fix all the corrupted file it will work without any problem. – yyc2001 Sep 4 '12 at 17:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.