We had one WFE server and upgraded to 2 WFE servers with a load balancer. We are using the SharePoint Server Standard edition. Because we are using the Standard edition and do not have access to BI webparts we needed a workaround to pull data from an excel file.

Users upload a daily excel file to a document library with some data. The custom webpart saves this excel spreadsheet to the C drive on the server and then displays the data.

Ever since we moved to the new servers the data is not being loaded from the excel file on the C drive. Could this be a security issue? I copied the code over to our development environment and it worked perfectly. I can't figure out how to trouble shoot this. Any help would be greatly appreciated.

Thanks, Ninel

2 Answers 2


Doing any local disk access from within SharePoint in a load balanced environment is risky at best. For example, which C: drive is it looking at, the one on Server 1 or the one on Server 2? Where is it writing the updates? Can it be updated on Server 1 but then loaded again from server2, etc., etc..

The first place to start would be to take a look at the LOGS folder on both servers and look for any errors at or around the time of the update. That error message should point you towards one of two likely problems: Permissions or Load Balancing

For Permissions, you will need to verify that the user making the change to the file on the C: drive as well as the Application Pool Account have WRITE permissions to that folder. Depending on the code in the web Part itself, you may only need to do this for the Application Pool itself.

To troubleshoot load balancing, you need to effectively disable load balancing by temporarily removing one of your servers from the load balancer. If the updates suddenly work then the problem is that there are two C: drives in the mix, one on each server. How you resolve that is up to your developers but I'm guessing it will involve a common share instead of the C: drive. It would be better if this were in SharePoint, of course.


Here's the solution in case anyone else has the same issue....

I was using the Microsoft Access Database Engine to read the excel files. Turns out this was installed on the old production server and not on the new ones. Once installed it worked perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.