Prior to a couple weeks ago I had never touched Sharepoint before so I apologize for any important information I may be missing that's pertinent to this question.

I am trying to get the Managed Meta Data service up and running. I had installed Sharepoint and been experimenting with a number of other features of the product and when I tried to set up the Managed Meta Data service by following an MSDN tutorial I found I kept getting this error when I went to look at it:

"The Managed Metadata Service or Connection is currently not available. The Application Pool or Managed Metadata Web Service may not have been started. Please Contact your Administrator."

I looked up the issue on Google and found a few recommendations. Permissions settings, a WCF hotfix and restarting IIS. Nothing I found resolved the issue so I figured I may have just screwed something up when I was experimenting with other features so I just went ahead and uninstalled Sharepoint and cleared the SQL database.

So I started from scratch, installed it as a Farm type and used the New-SPConfigurationDatabase command to create a new config database since this dev machine doesn't have Active Directory. That all worked without any warnings or errors so I went straight back to setting up the managed meta data service. Same issue.

Part of the problem I feel is that I haven't even seen this feature function so I'm currently unaware of what external settings may be at fault. Can anyone give me some recommendations on things to try or settings to check to resolve this issue?


EDIT: I'm fairly certain, again I'm new at SP so this may be incorrect, that all services are running. Here are the screenshots of the Central Admin and IIS App Pools.

Central Administration Service Application List

IIS Application Pools

Now I am aware that the Application Pools that the SharePoint Application Services use don't show in the IIS Application Pools list but I haven't found any way to verify that they are running.

  • Check in ULS log (Google ULS log viewer) and filter the following values Product:SharePoint Server, Category:Taxonomy, see if you have any more details.
    – Hugh Wood
    Aug 24, 2012 at 19:53
  • There are a lot of "Error encountered in background cache check Microsoft.SharePoint.SPEndpointAddressNotFoundException: There are no addresses available for this application." errors. I can provide the full trace if necessary. Aug 24, 2012 at 20:14
  • 1
    Okay EVERYTHING points to the service not running. Check that you started the 'Managed Metadata Web Service'. This can be found here: Central Admin > System Settings > Manage Services On Server
    – Hugh Wood
    Aug 24, 2012 at 21:04
  • Edited my question with some screenshots. I believe all appropriate services are running. Let me know if I can provide any other info. Aug 24, 2012 at 21:37
  • 1
    Here post expalining the same issue, sureshpydi.blogspot.in/2013/04/…
    – suresh
    Apr 24, 2013 at 11:07

2 Answers 2


Check my screen capture to where you should be looking.


Hi this is what you are looking for, as you have shown this is running, so you need to check to see if the account has permission.

First click it and select manage, what happens?

Does you're uls then show logs for a specific user denied? Check permissions on the ribbon on the page shown in my screenshot, you may have to make a claim. You can also add that user to have permissions to administrate this service if need be on the ribbon after selecting the service to see if there is another underlying issue.

But basically it's running so you aren't connecting for another reason and most likely permissions.


see this link


after starting service or apppool restart iis

another thing to check is Term Store Administrator must add in.

also see this apply permission for read


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.