Lately, my crawls seem to have stalled. I don't run a very big farm, and I only crawl the farm and a small Intranet portal, maybe a grand total of 180 GB of content, but the crawl will go on for a month and never finish.

Anyone encounter eternal crawls before? If so, how did you solve them?

  • Can you describe your server topology? is there a dedicated Index server, does that Index server use a specific web front end? What is your current patch level? – Mike Oryszak Jul 30 '10 at 19:51
  • @Mike-Oryszak: Thanks for your reply. Small farm. 1 WFE+Search, 1 dedicated Index, 1 SQL. All servers run SP2. – kbrimington Jul 30 '10 at 21:18
  • What CU/service pack are you on? I know the search crawler had some real performance issues early on that were addressed in service packs and CUs. Also have you had a look in your crawl log (via search admin) to see what, if any, errors you are encountering? – Nick Hadlee Jul 31 '10 at 6:11
  • I am facing a similar problem where in creating new SSP i dont see index option enabled, plus i cannot start search service as it gives me unknown error exception – Farrukh Jan 16 '14 at 8:42

In addition to Mikes answer, and if you are thinking of rebuilding your SSP to try and resolve the issue, I would do the following list of things first. These have helped me resolve search related issues before and are quicker to test than a creating a new SSP.

Note: My assumption is you find no errors in the logs mentioned previously and your service packs are up to date:

  1. Reset the index and then do a full crawl - this may take a while for 180GB but is better than a full SSP rebuild as a first step.
  2. If 1. fails then try stopping the index service via STSADM. It will ask you if you really want to do this because your index will be deleted. The answer is yes. Now you can start the service again via STSADM to provision a new index.
  3. If things are still not working then it might be time to try and create a new SSP as Mike suggests.
  • Thanks. I tried everything you suggested, but wound up on step 3 anyway. I appreciate the help. – kbrimington Aug 7 '10 at 5:49

Early on with MOSS I saw a lot of instability in the search and SSP functions. It sounds like Nick Hadlee had some similar experiences. I saw some issues where the indexer continued to lock up, and after some lengthy troubleshooting it was found that there was some corruption with the SSP. The SSP had to be recreated and then it started working again. This was all on SP1, long before SP2 was out and I haven't seen this since SP2 was released.

In addition to looking at the crawl logs, I would also check the ULS logs to see if there are timeouts or other errors relating to the indexing process. With that much content it might be a good idea to try adding a second web front as a dedicated web front end for crawling.

  • I appreciate the help, and the extra context. – kbrimington Aug 7 '10 at 5:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.