I don't get the point why sharepoint timer job stucks at "Initialized" status, even tho it worked properly once, any idea's ?

I know how to make it work again then but just dont understand the concept of it being hanged.


I tried clearing configuration cache which was the first thing I find people having trouble with but it didn't helped at all. Also it stops after 1st successful run which makes me wonder why would it go to Initialized stage after starting..


Yup you just need to stop start on the server services "SharePoint Services Timer service" should solve your issue.


This is a known bug comming from one of the servers or all of them causing invalid configuration cache


Clearing the cache to fix the Initialized state problem


more on server invalid configuration cache



Reset the SharePoint config cache using PowerShell



Problem I had was there was some problem with code in my timer job that let it run for a while and then stopped it so I changed logic of my code as well as increased time duration for timer job to run and it worked fine, FYI before time duration was 3 minutes. I increased it to 15 minutes.

Hope it helps if someone else came across same problem :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.