I have created a sharepoint 2010 environment in my office and I've created the UPS without any problems.

I've tried creating the same in office virtual environment..all settings were ditto but the UPS were constantly in "Starting" mode. Then I've googled and somebody recommended to configure Managed Metadata Service before UPS and I did the same and it worked like a charm.

I just want to know why as in the first place in office I didn't configure Managed Meta Data and followed the same steps at home but configured UPS after MM Data...whats the relation of both services and why it happened.

1 Answer 1


Edit: Managed Metadata service is not really required according to this post: http://social.technet.microsoft.com/forums/en-US/sharepointadminprevious/thread/01e0969b-037c-4846-832b-8cf806950ff0/

I found the same problems with UPS stuck in starting mode. However, the recommended fix for this was to reboot the server after changing the logon rights for the user account you are using to configure sharepoint.

Excerpt from http://www.harbar.net/articles/sp2010ups.aspx

"Changing the rights of a user account requires that account log off and log back on before the changes are applied. As the farm account is running services, you should restart the SPTimerV4 service, or better yet REBOOT THE MACHINE you wish to host UPS on now. If you don't, you will likely run into a stuck "starting" state when you provision the User Profile Synchronization Service Instance later on. More details at SharePoint 2010 User Profile Sync & Reboots."


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.