I am using Telerik Rad Editor for spellcheck for my wss 3.0 site. Site has been working all fine, but it suddenly just crashed without any action from my side. I got following error" Web Part Error: This page has encountered a critical error. Contact your system administrator if this problem persists".

After doing some research i found out this could happen because of some faulty safecontrol in web.config entry. I Checked all the safe control, and finally realized. It was these two entry that is causing error.

`<SafeControl Assembly="Telerik.Web.UI, Version=2010.3.1215.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4" Namespace="Telerik.Web.UI.Editor" TypeName="*" Safe="True" />
  <SafeControl Assembly="Telerik.Web.UI, Version=2010.3.1215.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4" Namespace="Telerik.Web.UI.Widgets" TypeName="*" Safe="True" />"

Without these two controls my rest of the site works but not spell checker. How do i fix this issue. I tried deactivating and reactivating webpart but it doesnt add those entries in web.config.

Any help would be appreciated.

Thank You

  • Please ask vendor specific questions on the relevant vendors forum site. You will have much better chance of getting the right answer. Aug 21, 2012 at 8:48

1 Answer 1


Are you sure the web.config is referencing to the right dll?

So to check goto the assembly and find the dll file Telerik.Web.UI.dll.

See the name matches the safe control, same witht the public key and version!!!

From what i can see you have Version=2010.3.1215.20 but isnt that for later versions not wss 3.0? shouldnt it be somthing like 2008.1.512.20 instead?


Hope this helps :)


Ok found the problem its todo with System.Web.Extensions that im guess is referencing to but it needs to be version 1.0.61025.0 in the GAC.

I think the problem is that you have .NET 3.5 installed on my

SharePoint server, which means that the System.Web.Extensions assembly

is version instead of 1.0.61025.0.

The RadEditor for MOSS is built using the Microsoft ASP.NET Ajax

Extensions 1.0 (version 1.0.61025.0). Since you are using different

versions ( for System.Web.Extensions and 2008.x.xxx.35 for

Telerik.Web.UI) you will need to add elements for

those two assemblies in the web.config file.


<assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35" culture="neutral" />

<bindingRedirect oldVersion="1.0.61025.0" newVersion="" /> 



<assemblyIdentity name="Telerik.Web.UI" publicKeyToken="121fae78165ba3d4" culture="neutral" />

<bindingRedirect oldVersion="2008.x.xxx.20" newVersion="2008.x.xxx.35" /> 



This should allow SharePoint to get the proper references and display the editor.

If you follow this it should solve your issue :)

  • Hello almostSharepointMaster, thank you for your input. I did indeed checked dll of the Telerik.Web.UI.dll. It is listed 2010.3.1215.20 version number and publickey token is 121fae78165ba3d4 exactly as listed in my web.config safe control. Any other suggestions? Aug 21, 2012 at 16:36
  • please look at the edited answer! it should be the solution to your problem :)
    – Ali Jafer
    Aug 21, 2012 at 22:13
  • Are we adding those inside <safecontrol> tags? Aug 22, 2012 at 19:06
  • It worked Excellent Thank You Very Much. I needed to add that code inside <runtime><assemblyBinding> and this did the magic <dependentAssembly> <assemblyIdentity name="System.Web.Extensions" publicKeyToken="31bf3856ad364e35" culture="neutral" /> <bindingRedirect oldVersion="1.0.61025.0" newVersion="" /> </dependentAssembly> <dependentAssembly> <assemblyIdentity name="Telerik.Web.UI" publicKeyToken="121fae78165ba3d4" culture="neutral" /> <bindingRedirect oldVersion="" newVersion="xxxx.x.xxxx.35" /> Aug 22, 2012 at 19:17

Not the answer you're looking for? Browse other questions tagged or ask your own question.