6

Is it possible to configure a SharePoint 2010 list to the default form for editing and viewing while displaying my custom InfoPath form only for new items?

1
  • +1 Thanks for drawing attention to this bug (Sharepoint Designer 2010 disrespects default manual settings without laborious tweaking them and Infopath Designer 2010 overwriting them on next publishing). Aug 22, 2012 at 2:39

3 Answers 3

3

In order to use mixed, i.e. both Infopath and default Sharepoint form templates, after creating Infopath form for and publishing to a list, you should remove association with Infopath form template and only then to choose again a specific as[x web part page...

Navigate to list > on ribbon List tab (under List Tools) > Settings > List settings > Form Settings > choose radiobutton "Use default Sharepoint form from the server" without checking "Delete the Infopath form from the server" > OK

choose radiobutton "Use default Sharepoint form from the server" without checking "Delete the Infopath form from the server"

Only then, in Sharepoint Designer 2010 Lists and Libraries > choose a List > in section Forms choose

  • newifs.aspx

and press on ribbon "Set as default"

enter image description here

Now, Infopath form web part page (linked eventually to infopath template) is used for new (aka create aka add) a list item while default sharepoint web parts (using default sharepoint lisr template) page for View and and Edit.

And you should repeat all the steps after each (quick) publish from Infopath Designer. No other choice, O am afraid...

Actually I posted in msdn forum about this user-unfriendliness:

2
  • +1000 if I could...been searching for hours trying to figure out why sharepoint isn't doing what I tell it to!
    – Grant
    Nov 8, 2013 at 13:44
  • This works great, except when using the Info Path form as a webpart on another page. I have a "New Account" page setup, which has an infopath webpart in it, showing the "New" view. Anyway, if i turn off using Infopath forms in List Settings -> Form Settings, then the Infopath Webpart no longer sees the list as an option having Infopath forms. Any ways around this?
    – russds
    Jul 1, 2015 at 18:28
0

You can change the default view for a form inside SharePoint Designer. Just edit the list forms to point to the .aspx page that uses your InfoPath form, then assign it to the New Form type.

enter image description here

1
  • 2
    I see that but after you create a new custom Infopath form things seem not so straight forward. It seems infopath takes over after that and these setting no longer work.
    – ChiliYago
    Aug 20, 2012 at 21:57
0

If the option "Use default Sharepoint form from the server" does not appear, you can go to Designer to modify the element. Inside it, in the forms section delete all the addresses that appear there. And so sharepoint uses the default froms again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.