The error reads as enter image description here

ok now it clearly states that there is already an iis website of that name but i'm not able toaccess it. what it means is that when i'm trying to find the website on inetmgr.exe unfortunately i cant find inetmgr on my system. now i dont know if it is not supposed to be there but before that i'll tell u a few things i did: Iam using windows 7 home basic, for dev purpose i've installed windows feature of iis, the install of iis went smooth. The applications like VS 2010 and SP 2010 install did had some minor issues for instalation but it did install. Could anyone please tell me why i do not have inetmgr on my system? How to get it ? i'm presuming the above error will go away if i delete the central admin instance that is present on my iis. Desperately looking for an answer and thanks in advance.

2 Answers 2


If for some reason it is not showing in your admin console you can load the powershell module and try the get-web cmdlets. Alternativley appcmd.exe list site if the site shows up you can get the ID and delete it with either Remove-Item or appcmd.exe delete site

If you still don't see anything than you could root around the applicationhost.config file, but you will probably be better off just uninstalling and re-installing IIS.

  • thanks for the response will try this and let you know if it worked Aug 16, 2012 at 5:49
  • tried to run these cmdlets in powershell installed by sharepoint running ad administrator but it gave error sying "the term appcmd.exe is not recognized as the name of a cmdlet" same was the response for other cmdlets. now u suggest uninstalling and reinstalling iis i presume that is disabling windows feature restarting machine and then reinstalling. please confirm so that i can try this. thanks Aug 16, 2012 at 16:01
  • appcmd is in the %windir%\system32\inetsrv directory. I don't know if that will be different on Win7 machine. And Yes remove the feature(s), restart and reinstall. Aug 16, 2012 at 18:47
  • thank you my friend much obliged it worked perfectly to delete the site Aug 17, 2012 at 5:46

I think your first step would be to follow these guidelines on installing Sharepoint on a Windows 7 box. IIS should be in Control Panel -> Administrative Tools.


  • mike that is what baffles me after installing the iis the iis is resetting hence iis is installed but the path you gave me do not have inet manager and neither did system32 folder showd its executable file. Aug 16, 2012 at 4:50
  • I would try to install all your components again, or let a script do it, Step 2, #8
    – Mike
    Aug 16, 2012 at 13:39
  • tried to install using script all cmds runs perfect but still no inetmgr Aug 16, 2012 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.