2

I have a new SharePoint 2010 site and have the Global Navigation on my publishing site set to show subsites and show pages. The subsites show on the navigation menu on top, but the pages I create do not. I am using manual sorting. Thanks.

3 Answers 3

2

This may seem overly simple, but it worked for me after spending many hours trying to fix the exact same issue you have.

Increase the number within the 'Maximum number of dynamic items to show within this level of navigation:' field in the Navigation menu. After I set this number higher (in my case, I had to set it to 30), everything showed up.

HTH, Oc3

2
  • Thanks for the answer. I think I just figured out my own issue. I was creating site pages rather than pages.
    – Sean
    Aug 14, 2012 at 15:08
  • @Oc3LoT thank you! I probably would not have thought of that...and this week the links have been "disappearing" and I was completely baffled because they were there under the settings. Jun 4, 2015 at 14:22
2

Simply: I was not paying close attention to the fact I was creating site pages or wiki pages rather than publishing pages. When choosing to create a new page, check where you are creating them. It will read "This page will be created in the Pages library". Pages should appear on the menu whereas Site Pages will not.

1
  • We need to Enable "SharePoint Server Publishing" Feature in the site where we want to add Publishing pages
    – shoab
    Oct 29, 2018 at 6:46
0

I don't know the details, but I had a similar issue. My onet.xml file missed navbar definition. I wrote a blog post about it: Can’t add a global site navigation link

<NavBar Name="$Resources:core,category_Top;"
    Separator="&amp;nbsp;&amp;nbsp;&amp;nbsp;"
    Body="&lt;a ID='onettopnavbar#LABEL_ID#' href='#URL#' accesskey='J'&gt;#LABEL#&lt;/a&gt;"
    ID="1002" />

Hope it helps, at least for others who encounter my problem.

1
  • Thanks mate. This will come in handy when I make modifications.
    – Sean
    Aug 14, 2012 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.