I work for The Smeal College of Business at Penn State. I am doing a project for the Supply chain program and I am creating an excel workbook in Sharepoint that uses a lot of UDF's. I have no problem accessing the workbook or using other UDF's, but when I try to use OpenWorkbookForEditing() I get the following stack trace:

System.Net.WebException: The request failed with HTTP status 503: Service Unavailable. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at ClassName.ExcelWebService.ExcelService.OpenWorkbookForEditing(String workbookPath, String uiCultureName, String dataCultureName, Status[]& status) at ClassName.ClassNameFunctions.testWriteCell()

Additionally, I've tried to access excelservice.asmx through PHP SOAP and have not received a response. Each attempt to connect to this service provides a 503 error in the IIS logs similar to the following:

2012-08-06 15:14:58 xxxx::xxx:xxxx:xxxx:xxxxxxx POST /_vti_bin/excelservice.asmx - 80 - xxxx::xxx:xxxx:xxxx:xxxxxxx Mozilla/4.0+(compatible;+MSIE+6.0;+MS+Web+Services+Client+Protocol+2.0.50727.5456) 503 0 0 59

I've tried changing most of the settings in Sharepoint Central Administration, as well as some of the setting in IIS. Does anyone know what could be causing this problem? Thanks.

I'm running a Sharepoint 2010 server on Windows Server 2008.

1 Answer 1


Have you enabled the Excel Service Application through
Central Admin > Manage Service Applications > Create > Excel Service Application.

Additionally, you need to configure the Trusted locations after you have created excel service application. This should include the path to the document library and probably having the user-defined functions checked.

  • I have done the above. The problem isn't with the excel service in general, but only when I try to access it through a SOAP call. Additionally, I can access the WSDL both programmatically and through the browser but making a call to any of the listed functions is when it fails.
    – Briton.W
    Aug 14, 2012 at 15:00
  • In Excel services application ,when you create trusted data locations settings you can also check the option "children trusted" and have the trusted location to be your site collection. This authorizes all child sites and lists to use user defined functions.
    – ArkoD
    Aug 16, 2012 at 5:45
  • I have checked this option as well. I can access all of the UDF's I've created, the problem only occurs in the UDF that attempts to call the OpenWorkbookForEditing() function and as the stack trace indicates, the error occurs on the SOAP call.
    – Briton.W
    Aug 16, 2012 at 14:19
  • I would do a fiddler trace and see what is preceding this 503. If that doesn't yield any results then a network trace on both ends to view the entire communication period. The service is running, so I'm thinking you have an authentication issue possibly obscuring the situation. Jan 30, 2013 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.