I am trying to deploy a feature to My Sites in SharePoint 2010 and nothing seems to be working. I did this perfectly fine on the test environment but can't seem to get it working on the production environment. Basically I keep getting this error:

Error occurred in deployment step 'Activate Features': Feature with Id 'd336ba21-03c8-4509-9dc5-a5515b11f670' is not installed in this farm, and cannot be added to this scope.

I am using this exact same project http://sp2010mysite.codeplex.com/releases/view/78702 no changes made to it yet to try and deploy it and I keep getting the error. I looked up the id and its the id for the My Content feature which is in the project so I have no idea why it complains. Also this exact same project works fine in another environment, is it my Visual Studio or SharePoint that' giving this problem?

I know I can do this manually using the management shell but I really want to get to the bottom of this issue.

Thanks for the help! Tudor

1 Answer 1


Is your production a multi server farm? I think you are facing the following issue:


It turns out that VS 2010 internally implements a call to the method SPSolution.DeployLocal That method is intended for troubleshooting purpouses of wsp files and as you can read on the MSDN documentation it performs a local deployment instead of an immediate deployment (Only to one sever of the farm)

  • I guess thats what I will have to do but I have one question, I have tried this and ran the commands Add-SPSolution and Install-SPSolution in the management shell on the server however nothing happens...the CSS isn't applied and I don't really know what the next step is. In central admin I can see it as a farm solution and its deployed but the masterpage it deploys isnt visible in the site settings...whats the step I am missing?
    – Tudor
    Aug 9, 2012 at 17:56
  • Nevermind, i figured it out, after deploying it I was looking under site collection features but its actually just site features. Thanks for the help!
    – Tudor
    Aug 9, 2012 at 17:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.