2

I've made a back up of site to produce a template file (WSP) in SharePoint 2010 online. I have then tried to import into my development platform, which is also SP 2010 online but keep getting the error that i have a missing feature...

THe ID of that feature is 69cadbef-ac7d-494d-9d0a-39a26e008377 and I belive its the BPOSExtranetFlag Feature.

Is there a way to install this on my SP?

Cheers,

S

1
  • Stephen, I see you marked the answer with final comment "Thanks Vardhamam but i cant see this anywhere on my SP?" Does it mean that you failed or succeeded to import your template? Aug 10, 2012 at 14:45

2 Answers 2

1

Here is an answer from Sharepoint Online (Office 365) support team:

Update:
I disagree with belief of the question author that:

  • "If the template is created from Office 365 SharePoint Online, you should be fine and they should work"

There are a lot of scalable issues in Sharepoint and Infopath, for example, just to mention a few:

Infopath Publishing wizard does not permit relative URLs with hard-coding initial reference

enter image description here

enter image description here

And it seems is not my own imagination. See, for example, the discussion Data Connection relative to site

The situation re is even more grave with Infopath forms of type/compatibility Workflow and/or Sharepoint List Form, which schema is locked and unmodifiable at all, see for example, my answers to question:

And these are only some of the problems with migrating/deploying anything (through templates or with aother approaches) containg Infopath forms to another Sahrepoint site

5
  • Thanks for the reply but I dont think this is relevent. Both Sharepoints in my situation are Sharepoint online/365.
    – Stephen
    Aug 9, 2012 at 16:24
  • The reply did explicitly tell that only "out-of-the-box" Sharepoint Online/365 templates are supported but not custom made in Sharepoint Online/365. Though, you may continue to understand it in your own way, that's your right Aug 9, 2012 at 16:59
  • Hey Gennday, that is my point. It states "If the template is created from Office 365 SharePoint Online, you should be fine and they should work." My template has come from SP online and is going to SP online. So it should work.
    – Stephen
    Aug 10, 2012 at 8:18
  • Hello, Stephen, I disagree, see my Update Aug 10, 2012 at 15:24
  • 1
    Hey Gennady, thanks for the detailed reply looks like we will have to build this from scratch again which is time consuming to say the least. I can believe MS would not make this easier. Many thanks for your input.
    – Stephen
    Aug 13, 2012 at 8:59
2

Since the feature was activated when you created the template of the site, you will require the same feature activated when you create a new site from the template.

4
  • Thanks for the answer, you were correct. I have now activated that feature on my target site. I now have another request to activate. 6E8F2B8D-D765-4e69-84EA-5702574C11D6 FAST Search End User Help Collection Enables FAST Search End User Help Collection Site. I cannot find this anywhere in my site features?
    – Stephen
    Aug 9, 2012 at 15:42
  • That is a site collection feature. It will be available on the root site on your site collection under Site Settings -> Site Collection Administration -> Site collection features. Aug 9, 2012 at 17:17
  • Thanks Vardhamam but i cant see this anywhere on my SP?
    – Stephen
    Aug 10, 2012 at 8:58
  • Is this the same site collection from where you created the template? Also, are you sure you are checking the site collection features and not the site features? Aug 11, 2012 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.