I am importing a exported site with several sub-sites to a new Site Collection of its Own but getting following error

Start Time: 8/9/2012 9:32:31 AM. Progress: Initializing Import. FatalError: Could not find WebTemplate #10099 with LCID 1033. at Microsoft.SharePoint.Deployment.ImportRequirementsManager.VerifyWebTemplate(SPRequir ementObject reqObj) at Microsoft.SharePoint.Deployment.ImportRequirementsManager.Validate(SPRequirementObje ct reqObj) at Microsoft.SharePoint.Deployment.ImportRequirementsManager.DeserializeAndValidate() at Microsoft.SharePoint.Deployment.SPImport.VerifyRequirements() at Microsoft.SharePoint.Deployment.SPImport.Run() Progress: Import Completed. Finish Time: 8/9/2012 9:33:06 AM. Completed with 0 warnings. Completed with 1 errors.

The site itself was created using a custom template, so I created new site collection based on that "CUSTOM Template" as well. Just to make sure I checked web templates in both old Site Collection and new Site Collection they are all same and this web template with id "10099" is in both of them. Can't figure out why am still getting error.


There was some problem with the site I exported, I dunno what was the problem but I created another site and imported it, worked fine.

  • tried almost everything, nothing is solving the problem :S Aug 10, 2012 at 12:02
  • I looked over hundred of articles but non of them is identical Aug 10, 2012 at 12:02

1 Answer 1


The error says that you are missing the template 10099 with LCID 1033. So you might have the templates installed, but SharePoint can't find the template that you have installed that has LCID 1033 (English US). Maybe you need to update the XML to be set to LCID 1033.

  • what would be the procedure of updating XML Aug 9, 2012 at 10:01
  • An probably very unsupported way is to go to your ..\14\TEMPLATE\ folder check at the top for your 1033 folder. (If that is missing then that is the reason for your error) if it exists open the folder named XML you will find in it. There you should find you custom XML template file it has an LCID in it verify that it's 1033. Hope this helps you. :)
    – Robban1980
    Aug 9, 2012 at 10:06
  • I checked LCID both have id as 1033, so dont think that can be the issue Aug 9, 2012 at 10:10
  • I have 53 web templates with that Id , I guess I will have to go through all of them manually Aug 9, 2012 at 10:38
  • sorry but Web templates are not stored in XML format either :S they are stored in Content DB, as explain at this link sharepoint.stackexchange.com/questions/43099/… Aug 13, 2012 at 11:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.