0

I have sharepoint 2010 and I experience problems with the "top link bar" - it is simply not available under "look and feel" options (there is a "navigation" instead).

I've read on a variety of sites that I need to disable the "SharePoint Server Publishing" to enable the "top link bar". That's what I did - for sure - but the "top link bar" is still not available.. how is it possible? What do I do to get the "top link bar" back to work?

  • Did you disable it for the site collection? – Mike Aug 7 '12 at 20:46
2

Not only "SharePoint Server Publishing" should be disabled, but under "Site Collection Features" you have to deactivate "SharePoint Server Publishing Infrastructure" also.

1

Even though top link was missing from settings, by adding /_layouts/15/topnav.aspx to your site URL you can open it

https://xxxxxxxx.sharepoint.com/sites/xxxxxxxx/_layouts/15/topnav.aspx

1

You need to disable both features like "SharePoint Server Publishing" and "SharePoint Server Publishing Infrastructure". Definitely, it will be visible(Top link bar). Because it is a default feature so Once you activate the publishing feature by default the Top link bar feature will be disabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.