I have a workflow in SP 2010 that I use to send an email whenever an item is added. I've included the 'Full details' in the body of the email, however when the email arrives it has massive spacing in between each line.

Looking at the HTML, it seems to be putting a 'br' tag at the end of the 'p' tags, so effectively getting double line.

Is there a way to remove certain text (in this case 'br' tags) from stuff (variable let's say) in SharePoint Designer workflows?


No, not directly! The built-in SharePoint 2010 workflow action Send an Email adds a
tag for each line break in the HTML source. Unfortunately, it does not have a property to disable this behaviour. Only way to get around this is to create a plain text field in the list and create a lookup on it in the WF action. Then copy-paste the HTML source without line breaks to this field on list items.

This is not a pretty work-around but you will otherwise need to code your own Workflow action or find a better one from a thirdparty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.