An example of my problem is at http://techfests.com/NWA/2012/Tracks/Cloud/default.aspx. Notice how the word "Microsoft's" is rendered as "Microsoft?s".

I input this in the Text Editor on the web part, and have tried plain typing, and cut and paste in Plain Text. The problem must assuredly be with Sharepoint because the problem is persistent across all major browsers. However, I mostly use Chrome to do my work in Sharepoint because I use a Mac.

How can I overcome this problem of HTML tags showing up in content?

3 Answers 3


Do you get the same behaviour if you edit from the browser rather than SharePoint designer?

If not, I'd guess you've got SharePoint designer set to something other than utf-8 as the charset.

You can change it by going to (in Designer 2010) File > General > Page Editor Options > Default Fonts.

Pick Unicode (UTF-8).


This is a long shot as the problem most likely is an encoding incompatibility like Ben suggests. However, it could also be an improper collation set in your SQL Server. SharePoint 2007 requires has specific requirements for the collation in order to work properly (which typically ends up something like 'SQL_Latin1_General_CI_AS_KS_WS').


Most likely this indeed will be a encoding problem, we have had the same issue before, however, the problem can occure while editing stuff in the master page, and thus preventing propper converting of the special chars to the correct utf8 coding ( wich SP will do if all goes well )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.