0

trying to set-up and consume a web service within SP using azure hosted services. I have written really simple code which compiles and deploys as a package. Followed this excellent walkthough... http://blogs.msdn.com/b/steve_fox/archive/2011/11/12/leveraging-wcf-services-to-connect-bcs-with-sharepoint-online.aspx.

When i try to add the external content type within SP i get the following message.

"Error loading URL ... this normally happens when URL does not point to a valid discovery document, service description, or XSD schema"

You can see the service here...http://splobservice.cloudapp.net/SharepointCallingService.svc

Anyone ran into this?

Stephen

1

Thanks for the reply Gavin and the link. Its taken a few days of head scratching but I eventually got the bottom of things...

The problem was the collation of the database (in my case SQL Azure) I had been using a DB created in SQL Azure which used Latin1_General_CI_AS, could not get it to work so decided to create a new DB using SQL_Latin1_General_CP1_CI_AS after reading a post on-line about the pitfalls of collation with SQL Azure.

Not sure why it has to be this collation or what can be done if your external DB is different to SQL_Latin1_General_CP1_CI_AS though...

Hope this helps someone.

Cheers,

Stephen

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.