Is there any option to remove default columns(eg: Created By, Modified By) from a custom list?

I do not want to hide the columns for a view, but I need to entirely remove/modify the default columns.

Eg: I need to have two columns Created Date and Updated Date instead of Created By and Modified By.

Even if I add two new columns with my specification I have to unnecessarily maintain those default columns with null values. I want to avoid this.

Any help will be appreciated, Thanks

  • Well as it so happens, the two columns you listed maintain themselves. Why would you have to put null in them? I haven't tried it but my gut tells me SharePoint wouldn't even allow this. If you get them removed from the forms and views the users don't have to know they exist and SharePoint can keep updating their data without worry. Jul 23, 2013 at 21:36

6 Answers 6


I would hesitate to remove those columns; there are lots of bits of SharePoint that expect those columns to exist, and I don't know how the system would perform without them.

However, you could hide them, and by 'hide' I mean something a bit more thorough than not having them in a view.

Using the SharePoint object model or Powershell (or CAML if you're writing your own list definiton) you could set the 'ShowIn...' Properties to false. For example, if you set 'ShowInListSettings' allows you to hide a column from the 'List settings' page. You can also control if they're available to use in Views, an if they appear on the new, edit, and view properties forms.

Then you could add the two columns you want on the list. The other columns would still exist - and be updated on create/update - but they wouldn't be visible to anyone.


Here's the powershell to make a field basically not exist to the end user

$w = get-spweb "siteurl"
$l = $w.Lists["ListName"]
$f = $l.Fields["FieldName"]
$f.ShowInDisplayForm = $false;
  • Will not work if field is required though Jul 23, 2013 at 19:04
  • It does not appear to no...
    – Xopher
    Jul 23, 2013 at 19:06
  • No, because if you can not set a value on a required field you will not be able to save the item Jul 23, 2013 at 19:34

What you need to do is you remove these columns from list. This is what I have done in the past. You need to remove the columns from the Item content type.

There are a number of ways to remove it so that it does not appear on edit form one way is:

Follow this:

1) Go to List settings-->Click on Advanced Settings-->Select Allow Management of Content Types=Yes radio button

2) Click on particular content type where title field exists--->click on Title column--->Select Hidden(Will not appear in forms) radio button ---> click on "OK" button

3) Now go to your list and check (by click on new ---Title will not visible) and similarly you uncheck the Title column from Default view(It won't appear in View)

Second is remove from the list schema if it is a custom list and do this:

(this is in the in your schema:

This is the id to column you want to remove.


Since these fields are read-only, you cannot change them using the UI, but you can change them using the following options:

  • thanks for your reply. I see that I haven't explained my query properly. This was not what I was looking for. I've modified my question. Can you be any help here?
    – Jith
    Jul 21, 2012 at 3:44

1) Create your own Custom Content Type with the Columns "Created Date" and "Updated Date"

2) Add this content type to your Custom List

3) Make it the default Content Type.

4) Remove the "Item" and "Folder" Content Types from the List.

This works through the UI as well as SharePoint Designer and Visual Studio.


It's pretty easy, you just have to follow this steps:

  1. Open document library
  2. In the ribbon select "Modify the view "
  3. Uncheck the columns that you don't want in your document library including the default one.

Or follow the Column hide using the content-type as shown in the other answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.