I saw similar post on SO but it didn't worked out for me. I've created a List Definition project in VS. On one of the fields I set type to Int instead of Integer, and tried to deploy List Definition.

<Field ID="{FD283A24-9FD2-430C-938E-5B180473A141}" Name="NewServiceOfferingsActual" DisplayName="New Service offerings" Type="Int" />

After that I got this exception message. Now the problem is, I can't go to list settings page and delete this field, because I don't have list instance at all.

I can't find ContentType in Site Content Types either

    Description="Service Offerings"
    Group="Custom Content Types">

There is no Content Type with the name ServiceOfferings.

I tried to find this field using approach suggested in similar post, but in generated XML file I can't seem to find the Field by it's name nor by ID.

I've checked all my Content Types, neither have this field.

I've even generated CSV file, that contains detailed information about fields of content types in my site collection, but again I can't seem to find the field.

set-variable -option constant -name url -value "http://myserver"
set-variable -option constant -name out -value "c:\ListOfAllCTs.csv"  
# End of settings

$site = new-object Microsoft.SharePoint.SPSite($url)
$cts = $site.rootweb.ContentTypes
echo "Processing..."

'"CT Name"' + `
',"CT ID"' + `
',"CT Description"' + `
',"CT Group"' +
',"Field Title"' + `
',"Field Internal Name"' + `
',"Field ID"' + `
',"Field Group"' + `
',"Field Max Length"' + `
',"Field Description"' | Out-File c:ListOfAllCTs.csv 

ForEach ($id in $cts)
      ForEach ($field in $id.Fields)

            '"' + $id.Name + `
            '","' + $id.Id + `
            '","' + $id.Description + `
            '","' + $id.Group + `
            '","' + $field.Title + `
            '","' + $field.InternalName + `
            '","' + $field.Id + `
            '","' + $field.Group + `
            '","' + $field.MaxLength + `
            '","' + $field.Description + `
            '"' | Out-File c:ListOfAllCTs.csv -append




echo "Finished!"

I know I can restore the backup of Site Collection, but it's the last thing I'd like to do. I'm using SharePoint Foundation 2010.

So, how this field can be removed ? I'm getting exceptions whenever I try to navigate to Site Columns Gallery, and I can't add new columns to content types.

  • I had same issue before and this approach worked for me(to delete the column, look for these lines in the article below SELECT * FROM [ContentDBName of Site collection ].[dbo].[ContentTypes] WHERE Definition Like ‘%GuiId of your site column%’ Delete FROM [ContentDBName of Site collection ].[dbo].[ContentTypes] WHERE Definition Like ‘%GuiId of your site column%’. : abdulazizfarooqi.wordpress.com/2012/07/13/… Jul 18, 2012 at 22:39

1 Answer 1


I had same issue before and this approach worked for me(To delete the column from Content DB, look for these lines in the article below:

SELECT * FROM [ContentDBName of Site collection ].[dbo].[ContentTypes] WHERE Definition Like ‘%GuiId of your site column%’

Delete FROM [ContentDBName of Site collection ].[dbo].[ContentTypes] WHERE Definition Like ‘%GuiId of your site column%’.


  • You might also try this PowerShell to see if you will get en error for the field: To determine what field is causing the error run this PowerShell script. The PowerShell should terminate with an error, along with the name of the erroneous field. $web = Get-SPWeb portal/site $fields = $web.Fields foreach ($field in $fields} {write-host $field.id} This script will loop through all the field types. You should receive an error similar to this: Jul 18, 2012 at 22:54
  • I have just copied the PowerShell from a web article, I have not tried this approach muself before, I used the SharePoint Manager and PowerShell print to a file both of which worked for me, but if they didn't work for you they may be this might. Here is the link : jshidell.com/2012/06/07/… Jul 18, 2012 at 22:58
  • Thanks for reply, I tried that approach, but I can't find Content Type. I tried both, query using Definition and ContentTypeId, but no luck so far. I can find other custom content types that I've deployed, but not this one. So it turns out, that ContentType wasn't deployed, so how can I get this exception, if Content Type wasn't even deployed ? Or am I missing something else ?
    – Michael
    Jul 19, 2012 at 20:10
  • Can you open your Site Settings -> Site Colmuns page and see all the rest of the site columns there. If you can't open that page and you get error, then it means you have a corrupted field. Jul 19, 2012 at 20:35
  • nope I can't open Site Columns page, but I have no clue, how can I find that corrupted field, and remove it from Content Db. One thing for sure, I can't find it in ContentTypes table, because as I mentioned earlier, I don't have ContentType in Content Db. Any other suggestion, where I can look for corrupted field ?
    – Michael
    Jul 20, 2012 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.