I've configured a new user profile service application and synchronisation service too, which I have also ran and can see it says there are 128 User Profiles.

Also, under 'Manage User Profiles' I can search for any user and see their details (have to search each user, doesn't show full list for some reason).

However, I'm getting an error when I'm creating a workflow that sends an email to me with my manager's name in the body of the email. This is the error I get after I create the item and the workflow runs:

"Workflow failed to get user profile for user: xxx/HAdes"

I've tried all sorts that google has offered (enable netbios names, reset IIS, restart machine, resync etc) but still no joy.

Any ideas?



Did you find a solution to this issue? I'm having the same issues myself. The only difference is that instead of it saying "Workflow failed to get user profile for user: xxx/HAdes" it says "Workflow failed to get user profile for user: HAdes"

I think this may solve my issues but I would rather not rebuild Mysites and UserSync from scratch to run this properly:

$upsa = Get-SPServiceApplication –Id [GUID of User Profile Service Application] $upsa.NetBIOSDomainNamesEnabled=1 $upsa.Update() # To get the GUID of the User Profile Service Application run Get-SPServiceApplication.

If I look at my users in Central Admin I see they are DOMAIN/USER.NAME so maybe redoing the user profiles with that PowerShell option is my only option?

| improve this answer | |

I just tried deleting and recreating the User Profile Service, this time I set the DomainNamesEnables to "true" before setting up and syncing users. Looks like I'm having the same issues though. I can search for people perfectly fine. That all works well. Everything else works. The odd thing is that the workflows worked originally BEFORE I had even got the User Profile Service synced. I feel like I'm missing something small.

I'm just doing a basic approval workflow when an item is added to a list. I still get error "Workflow failed to get user profile for user:FIRSTNAME LASTNAME"

| improve this answer | |

For both of you, it may be worth confirming that there's good manager data in Active Directory. I've seen this issue before where there's either no manager, or bad manager data in AD where your workflow can't properly identify who the user's manager is.

Your other issue may be permissions related. Is this a standard SPD workflow? If so it's likely executing under the user's context. If the general user population doesn't have read access to the UPS SSA then the workflow won't be able to read the profiles even if you can as a farm admin. The "failed to get user profile" error makes me think there may be a permissions issue here. If you simply provisioned UPS but didn't assign those permissions that could be your hangup. You may have knock-on issues with search being unable to perform people search if the search content account hasn't been granted the right permissions to the UPS SSA also.

| improve this answer | |

I just figured out what my issue was. I was using an older workflow I made with sharepoint designer and I was getting that error. I created a new one from scratch in sharepoint designer and that worked perfectly. The older workflow must have been holding onto something or searching for the wrong username. I'm up and running now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.