I set up a managed account for my Sharepoint 2010 Web Application. I did this by first creating a local account on the system (in the "Users" group), then set up the web application, providing the managed account info when doing so.

Everything worked great for while until I tried to save a site template, and I noticed errors in the ULS log basically stating that the permission to the C:\windows\TEMP directory were insufficient. So I added the "managed" local account to that folder giving full permissions and the site templates worked.

So I am curious, what is the right way to set up a managed account with respect to local server permissions? Did I miss a step perhaps I should have added the user to a group other than Users? Any help is appreciated even RTFM with a link would be great, I've been unable to find info on this aspect of managed accounts.

1 Answer 1


Well in general it's not recommended that you run your SharePoint as Stand-Alone and this is the only mode that supports local users.

The recommended practise is to run as a Complete Farm and use domain account, when you use domain accounts as application pool accounts they will/should automatically be added to the group WSS_WPG and thereby be given access to c:\windows\temp

I'm not 100% sure the WSS_WPG group exists when running Stand-Alone but you should check that and if that's the case then give the account access through that.

  • Thank you Per -- the WSS_WPG group does exist in Standalone. I appreciate the knowledge. Thanks again.
    – mikey
    Jul 13, 2012 at 20:13
  • Just wanted to update this. When I checked the group membership for my managed account user, I found it was already a member of the WSS_WPG group. So, giving the managed account a bit more permissions on the c:\windows\temp folder did the trick. I suppose that an OOTB managed account with WSS_WPG membership isn't enough to create a site template, it should really be done by a member of the WSS_ADMIN_WPG group. Most likely if I'd gone the powershell route as admin I'd not have had a problem.
    – mikey
    Jul 14, 2012 at 14:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.