Currently we are working in a process where documents are uploaded, then downloaded, modified and re-uploaded as a NEW file, not as a new version of the same file. However, When I upload the documnet, I get following error

I tried the following:

  1. Found that there is a previous file uploaded, which was modified to make this new one.
  2. Changed filename - didn't work, same error (though anyways there is no file with the same name)
  3. In windows, I "removed all properties and personal information of the file" - didn't work, same error
  4. Copied all sheets into a NEW workbook in excel - that did the trick.

The solution in point 4 is bit impractical as because it means that every now and then we will need to keep copying sheets to new excel files which will be tedious in the long run, so we need to look for a workaround.

Any help is appreciated.


  • 1
    I would love to know the root cause of this issue as I've hit this exact same error on one of our Document Libraries. I ended up having to create a new DocLib and then use Explorer View to move the documents. Using Content and Structure to move them just moved the error to the new doclib as well. – Dave Wise Jul 11 '12 at 14:24

Are you programmatically doing this?

Have you tried checking with Document Inspector for any corrupt/invalid properties??


regards, KS

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.