I have been working on a SharePoint 2010 solution on a server using Visual Studio. Unfortunately the server decided to die on me. Fortunately I have the solution backed up using source control and had another server ready to go. After changing the necessary site url property on the project in visual studio, I used the deploy option in the build menu and it seemed everything was successful.

However, none of the features show in the site collection features, site features or farm features. The folders and files exist in the features under the 14 hive and the assembly is in the gac.

Having no luck with this I tried packaging the wsp, uploading and activating it manually (something ive not done before). This throws up an immediate error with a correlation id allowing me to find something in the logs.

Some of the logs seemed to be complaining because of farm-scoped features. As I have never done a manual deploy before I dont know if I have to do the differently scoped features separately (visual studio used to do it all at the same time for me).

The only other error I can see is "Missing one or more of the following attributes from the root node in solution Bistech___Provision_Sites.wsp: assembly '', type ''"

The solution is not a sandboxed solution and I have all the permissions etc i need (farm admin, site collection admin...)

I hope someone can help because I am out of my depth on this one!!

Thanks in advance for any response


  • 1
    What Features are included in the solution, and what scope are they? Did you deploy the solution to all web applications or to a specific one?
    – James Love
    Sep 9, 2012 at 9:15
  • Can you post more of the error text?
    – Lou
    Nov 25, 2013 at 21:09

1 Answer 1


Make sure you are rebuilding the project using the same key file (.snk) you were using to strong name the DLL in the previous project. If that key is no longer available then you will have to generate a new one. Unfortunately, this means that all references in SharePoint to the old one are now broken and will need to be deleted and recreated.

  • Thanks for your response. The original .snk file remained as it was under source control also. It has been rebuilt with it.
    – Zak
    Jul 6, 2012 at 20:30
  • 1
    Have you tried pushing it down to only one web application instead of them all?
    – Dave Wise
    Jul 6, 2012 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.