A user was trying to upload documents to their site collection and reached the quota limit. I increased the quota for him but he is still getting the same error that the quota has been reached when he tries to upload documents. What we've tried that didn't work:

  1. I had the user clear his cache and re-open site thinking maybe the setting had somehow been cached
  2. I double checked in Central Admin that the site collection in question was not locked, and that the increased quota amount was sufficient for his needs
  3. I also checked in Central Admin what the file upload size limit was, and verified it was not being hit with his new upload

I should also mention that I've increased this particular quota in the past, and it took effect immediately with no issue.

Since I'm new here evidently I'm not allowed to post images, but I had screenshots showing that the quota template for this site collection is set to 4 GB, and one showing that the old value of 3 GB is still showing up in the storage usage analytics report for the site collection.

What am I missing? Is there a timer job or something that pushes the updates to the site collection that's failing?

  • You can show images when your rep gets higher, stick around! Commented Jul 5, 2012 at 22:07

1 Answer 1


In my experience if you update the quota template it does not get applied to the sites that already use it.

Through Central Administration apply another quota template to the site then reapply the previous one.

If you have 100s or 1000s of sites to update you can use the following PowerShell.

Hence, If you want to update the same template just set $OldTemplateName and $NewTemplateName to the same value.

$OldTemplateName = "Bad Template"
$NewTemplateName = "Good Template"
$WebApplicationUrl = "http://my/"
$contentService = [Microsoft.SharePoint.Administration.SPWebService]::ContentService
$quotaTemplate = $contentService.QuotaTemplates[$OldTemplateName]
$replaceQuotaTemplate = $contentService.QuotaTemplates[$NewTemplateName]
$webApplication = Get-SPWebApplication $WebApplicationUrl
$webApplication.Sites | ForEach-Object { try { if ($_.Quota.QuotaID -eq       
$quotaTemplate.QuotaID) { $_.Quota = $replaceQuotaTemplate } } finally { $_.Dispose();}}
  • Thanks Randy! That was the issue, after I chose a different quota template and reapplied the original template, the upload error went away.
    – Wendy Neal
    Commented Jul 5, 2012 at 21:35
  • Always go and check the specific site just to make sure the changes are applied. Commented Jul 5, 2012 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.