0

In our farm we have the following issue: Created a workflow with a few easy steps. The first step is a "assign a variable" step, all following steps are within an impersonation step. That workflow works about 7-10 days, after that all new workflows stops after the first step just before the impersonation step. The workflow history displays: "Canceled" by "System Account" without any more info. The ULS log shows nothing regarding workflows (log level is set to "High", because it is a production environment).

Any ideas, what could cause the workflow stop working after a few days within the impersonation step?

1

I think we found the issue. It is caused by the workflow itself, because the workflow fires on item change and on item create. The item is changed within the worklfow and causes a recursion. I found this article (which is for 2007) which describes it in detail. However, it is strange that it worked sometimes and sometimes not. Maybe a timing issue somewhere. We have now changed the workflow so that it won't happen again (hopefully).

0

Sometimes it can be cancelled because of assigning null value to a string type variable.

  • Thanks for that hint, but its exactly the same workflow on the exact same list item, so there should be no difference. So assigning null would always not work, but in our environment it stops working after a week or so. – marco Jul 10 '12 at 6:27
  • Did you check the list permissions? Do the permissions cause this? – newbie Jul 10 '12 at 7:24
  • Yes, the permissions are not the problem. We tried a lot more things, and found that it works sometimes and sometimes not. – marco Jul 10 '12 at 10:35
  • I have read your last comment. Actually, I use flags to prevent changes on recursive workflows. Maybe you can use a flag too. Hope, it will not happen again :) – newbie Jul 10 '12 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.