We recently had a few users in our environment upgrade to Excel 2010 and all these users are now experiencing the same problem where they cannot edit files by clicking them in the library or using the drop down edit feature. The more annoying part is there is no error message it just simply doesn't launch the program. The current workarounds I proposed is selecting "Read Only" and enable editing in Excel or downloading and re-uploading the document.

I'm just wondering if anyone has any idea where to look or if they have resolved this problem before.

Here is my recent documentation on the problem:

  • Happens in WSS 3.0 and 2010 Enterprise
  • Happens in XP running Excel 2010 (Tested Windows 7 and had no issue)
  • Advanced Settings are set to open applications in clients computer
  • I tried repairing the Office 2010 installation and noticed no change

Any tips will be appreciated

  • I had a similar problem and fixed by removing Office cache.
    – Karu
    Commented Sep 16, 2014 at 22:11

1 Answer 1


Try any of the following:

  • In IE, go to options > connections > Lan settings, turn of "Automatically detect settings"
  • Make your SP site is a Trusted Site in IE
  • Add SP to the Trusted Locations in Office
  • Turn off all the Protected View options in the Office Trust Center
  • Delete the Office cache file:


If none of the above solutions work, provide more information:

  • Is this a XP 64-bit OS?
  • What version of IE are you using (7, 8)?
  • What IE architecture are you using (32-bit or 64-bit)?
  • Was there any issue when using XP and Excel 2007?
  • Only the users that are using XP and Excel 2010 have this issue?
  • Can any of the users open Excel documents created in Excel 2010?
  • Have you tried creating a brand new document library (without changing any settings) and uploading one of these excel documents and see if they can open it?
  • Can a site collection administrator open these documents?
  • Have you tried the Explorer View to see what happens?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.