We need to list documents, list items, etc from a Sharepoint Search Server Express Index by the created date. The problem is we can't find it in the index even though we've tried to map it to everything we can think of.

In the Central Admin/Shared Services Administration you will go to the Search Administration page. I added the metadata properties of most of the date/time fields I could find that could be the Created Date that I am looking for. I have tried all the following properties and none of them return the date I am looking for.

see https://i.sstatic.net/vT1mk.png

I then “Reset all crawled content” and ran a full crawl.

We are using Search Server Express 2008 and WSS 3. We call the Microsoft.Office.Server.Search.Query.FullTextSqlQuery to return the data.

We use a query like this:

@"SELECT Title, SiteName, SiteTitle, Write, Path, Filename, ListId, ListItemId, Created,CreatedBasic14,CreatedBasic16,CreatedBasic4,CreatedDC, CreatedOffice10, CreatedOffice11,CreatedOffice13,CreatedStartDate,CreatedStartDate1,CreatedPublishedDate,CreatedDateOpened FROM portal..scope() WHERE (CONTAINS (contentclass,'STS_ListItem_DocumentLibrary')) AND ContentType <> 'Folder' AND (SITE='" + SPContext.Current.Site.Url + "')

My question is what property do I have to set that will allow me to get the correct created date?

2 Answers 2


Mapping to 'Basic:15(Date and Time)' crawled property worked well for me to get creation date of a list item.

You don't need to reset the whole index, full crawl should be more than enough to refresh mappings.

  • Thanks @Maksymilian! - our problem was that we had another field in the mapping that was being read first. That field had a "blank" value so it was taking that.
    – dirq
    Commented Jul 11, 2012 at 12:52
  • Psst @maksymilian - Answer this on stackoverflow and I'll give you credit. ;) stackoverflow.com/questions/11231004/…
    – dirq
    Commented Jul 11, 2012 at 13:02

Mapping to the Basic:15(Date and Time) seems to be working if I create a new metadata property and add that mapping to the new metadata property. But when I tried to just have it in the "Created" metadata property that was already there it doesn't bring back the expected results. Both properties are identical except for what I called the property name. I even reset and ran a full crawl. Maybe Created is just a reserved word and shouldn't be changed. Either way I needed to create a new mapped property to get it to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.