My name seems to be appearing as DOMAIN\UserName for sites that I create (and sometimes sites that others have created as well) rather than Forename Surname, why is this happening? It is on an Active Directory domain.

If I try to set up synchronization (Application Management > Manage service applications > User Profile Service Application > Configure Synchronization Connections > Create New Connection) I get an error:

Cannot navigate to the requested page while User Profile Synchronization is running. Please wait for the current Synchronization run to finish.

There are no timer jobs running at the time, plus I tried a reboot and got the same error message.

I also try to start Forefront Identity Manager Service and it stops straight away (domain account or local system account):

The Forefront Identity Manager Service service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs.

Any ideas?

User Profile Synchronization Service status is 'Stopped', but when I click 'Start' it asks for a password, where the account is 'NT AUTHORITY\NETWORK SERVICE' (and can't be changed).

Edit 2:
Using stsadm -o sync -listolddatabases 0 I get:

User Profile Application 'User Profile Service Application' - Partition '0c37852
ID: d3c78ad7-11a5-403a-82c8-5225b410f199  Synchronized: 5/24/2010 11:00:01 AM
ID: 11503409-d60d-437f-bcea-72fe4f9cf156  Synchronized: 5/20/2010 2:00:00 PM

stsadm -o sync -deleteolddatabases 0 results in a failure. Checked the log file and there are a lot of entries regarding stsadmin, a few exceptions (access denied) even though I am both a server administrator and a farm administrator (everything is all and the same server as it is for testing). Log file is plain text, isn't there an easier way to view/query it rather than use notepad?

3 Answers 3


Setting up User Profile Sync isn't as straightforward as plugging in the domain info and starting a sync - you have to start the User Profile Service in the Services on Server page, wait for it to provision (usually takes about 5-10 minutes, this is what installs and configures the associated Forefront Identity Manager services), then bounce IIS and then setup your Active Directory connections. I had a lot of trouble with this in the alpha\beta - I documented the steps here, although I'm sure the MSDN blog guides are the most solid.

Your AD account needs specific permissions as well (the Replicate AD Changes permission) on the domain - and the configuration partition.


  • If I could actually get to the page for entering the domain information it would be a start... however, it keeps redirecting back, saying it is already running - which it isn't as there are no active jobs.
    – Sam
    Aug 24, 2010 at 8:56

Try the June 2010 CU hotfix KB983497 (aka the UPA patch)

  • Tried that, Forefront Identity Manager still does not start. User Profile Synchronization Service is staying on 'Starting'
    – Sam
    Aug 18, 2010 at 12:04
  • Try to recreate the whole UPA Aug 18, 2010 at 19:12
  • Is SQL and SP on the same box? Aug 18, 2010 at 22:07
  • There is a dev box (which has all of sharepoint on) as well as a farm (sql, application and web services on different boxes)
    – Sam
    Aug 24, 2010 at 8:58

I think you have two issues; the display name issue on the site and the user profile sync issues you mentioned.

Since Foundation doesn't have centralized user profiles, it uses a localized User Information list. With Server, this is still in place and there are some timer jobs that synchronize the information between the central profiles and the site collections. I have seen this issue come up a few times when there was something preventing a site from updating.

You can run the following stsadm commands to validate and repair.

stsadm -o sync -listolddatabases 0

If there are any sites returned, then they are currently not updating. You can run the following command to reset them so that they will run during the next job (within 2 hours).

stsadm -o sync -deleteolddatabases 0 

To setup the sync with AD, the configuration needs to be configured. Here is a link that should hopefully help.

  • Get an error with deleteolddatabases: A failure occurred during the processing of this command. Check diagnostic logs for more information.
    – Sam
    Jul 12, 2010 at 15:42
  • So were there sites returned after the -listolddatabases call? When you run the command, are you logged in as a farm administrator? Try checking the logs and see if there is anything useful to point you in the right direction. They are located in the 14 hive. Jul 12, 2010 at 16:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.