10

When checking out the Home.aspx page I receive this error.

Server error: The URL is invalid. It may refer to a nonexistent file or folder or refer to a valid file that is not in the current Web

I have read and checked the log files based on this article and we are not having any issues with disk space.

The file is checked out (even though it isn't initially indicated) and all of the webparts go missing. It happens both in the designer and from the web interface. I am really at a loss as to what to do to fix this issue, any suggestions would be greatly appreciated.

Thanks!

  • Is this a publishing page? You might have an issue with the publishing page layout URl being invalid or pointing to a URl which is not an alternate access mapping. If you go into the pages library so you can see the home page listed there then hover over the value for the layout field on that page, look to see what the URl is. Is it valid? – PlanetWilson Jun 27 '12 at 9:10
  • Are you using the hostname, ip address or localhost to connect to the site? I would double check that. You could also try fiddler and inspect the actual request. – Joel Tipke Feb 14 '14 at 22:08
  • Do you either fiddler or IE Dev tools (or any other browser based debugger) look for authentication/access denied errors - my guess is that within the actual master pages some artifact (image, css, etc.) you are not allowed to access it - which throws this error. – Marius Constantinescu - MVP Mar 15 '14 at 11:56
3

This is most probably happen in following case. Please check some checkpoint to solved this error:

  1. SharePoint Database Server should have minimum 1 GB free space.
  2. SharePoint Site application pool user/password is not expired.
  3. Reset IIS and Recycle Application Pool of SharePoint site.

This will solve your error.

  • Had this happen and even deleting files or emptying the recycle bin would error out. The transaction log in a pre-production environment wasn't truncating and it ran out of space. – Graham May 16 '18 at 21:02
2

I have faced the same issue and I have done few changes in DB settings as below.

  1. Check the auto growth size of that DB
  2. And see the Maximum file size limit increase it to around 2048 MB.
2

I had the same problem and found this very simple solution which worked for me.

The above link offers more detail, but simply put, this is what I did.

Take content from problem file and copy into new file. Rename old file (e.g. home_old.aspx) and then rename new file (home.aspx). Very simple.

  • database logs drive was full – Moji Oct 27 '14 at 11:13
0

Open the page using the "Preview in Browser" and this will show you which webpart on the page is invalid. You can then either comment out the webpart code or append the URL in the browser with ?contents=1 and remove the webpart from the page.

0

A corrupt column was the culprit for me. This is what I did wrong:

  • Created a single-line text column and added it to my document set content type.
  • Set it as a shared column in document set settings.
  • Indexed the column.
  • Ran script to update that column for all documents and document sets. (I think this is where the column broke because I forgot to add it to the document content type)
  • No longer able to upload documents or edit properties in this library.
  • "Fixed" the issue by deleting the column

EDIT: The error happened again! However, now I think the issue is being caused by indexing columns. This is what I did wrong this time:

  • Created 3 new columns
  • Ran a script to update those columns
  • Created an index for the new columns while the script was running
  • Created an index for an EXISTING single-line text column (NOTE: the script was running, but I was not updating this column)
  • "Fixed" the issue by removing the index for the existing single-line text column

I don't think my script is the has anything to do with it considering this is the second time adding an index for a single-line text column has caused issues.

Will test and update my answer with results.

0

I too had this issue, found out there was an issue with the file itself, copied the contents to another file and then was able to upload file successfully.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.