I am seriously sick because all of sudden variations pages have stopped working. I have no clue on how can I fix it :( See below:



  • Does this happen for every page? Sounds like your variations relationships table is screwed... – James Love Jun 24 '12 at 19:41
  • yes, this happens for every variations page. Do you have reasonable suggestion or solution to it? – Geek Jun 24 '12 at 20:21
  • Well there's a hidden list at the root of the sit ecollection that maintains mappings of pages in the root variation to all the others. Problem is, it's all GUIDs, I think. There might be tutorials on the web for rebuilding this mapping list. – James Love Jun 24 '12 at 21:35
  • Jamey, do you know any good ones? – Geek Jun 25 '12 at 10:18
  • Do you see this error on all site pages and what is the size of the Content DB? – Falak Mahmood Jun 27 '12 at 18:10

In your case, as you said, the size of your Content Database is not large (I assume you might also be not on production farm) therefore I would recommend you restoring the Content Database from any other server or backup source (Production) again.

| improve this answer | |
  • Thanks Falak, I will try it but it is not Production Farm. – Geek Jun 27 '12 at 18:48

There is a built-in tool variationsfixuptool that allow to self fix issues within that variation relationship hidden list.

stsadm -o variationsfixuptool
          -url <absolute web URL> 
         [-label <label to fix or spawn>]

In your case that's the -fix that will be helpful as it will allow you to correct

  • Missing Variation Group ID on source site or source page
  • Missing relationships list entry for source or target page or site
  • Missing Variation Group ID on target site or target page
  • Different Variation Group ID in source site/page and target site/page

You also have the -scan switch to first get an overview of what could be broken.

Hope it helped.

| improve this answer | |
  • Nope, it didn't help. I tried to run the scan/fix and but it throws Object reference not set to an instance of an object message – Geek Jun 25 '12 at 10:17
  • Did you check your variation labels and relationship list using a tool like SharePoint Manager 2010 (portable, doesn't require installation and lightweight) to check inside these two lists if you can spot a culprit (missing labels, etc.). Any backup that you could restore to check if it's an environment issue (timer jobs ?) or a content issue ? – Francois Verbeeck Jun 25 '12 at 10:46
  • SharePoint Manager was helpful but I couldn't figure out the what's culprit inside relationship list – Geek Jun 27 '12 at 18:22
  • You should ensure you have valid backup from now and 1. delete all non source variation labels & sites. Review the timer jobs entries for that web application to ensure all 4 the jobs are runnings and then check the variation logs within your site collection to find any culprit. You can also investigate your ULS and progressively recreate a new variation label (hierarchy will be created within 24h so you should force the job to run immediately). Removing as much content as possible (hence the backup) will help to spot the culprit(s) – Francois Verbeeck Jun 28 '12 at 8:34

Can you look in the list:-


and ensure the values look correct?

You should have the following fields present:-


Display Name



Is Source


Heirarchy Is Created

| improve this answer | |
  • I can't see the screen as you suggested. I got the same error messages as seen above. – Geek Jun 28 '12 at 14:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.