1

After upgrading to sharepoint 2010. SharePoint Designer workflow is starting automatically on principal worklfow but not starting on secondary workflow on task list when the item is created by incoming email.

the problem is due to the system account used to create the item in the first library.

What solution can apply to solve this issue?

2
  • What do you mean by "principal" and "secondary" workflow? I'd guess you have a workflow set to run when an item is created, that executes another workflow at some point. Is that it? Commented Jun 21, 2012 at 11:00
  • the scenario is using incoming email an item is created in principal list which trigger principal workflow automatically then a task item is created in the task list. the workflow associated with the task list does not trigger in the log I see can't trigger declarative workflow with system account.
    – kadben
    Commented Jun 21, 2012 at 15:20

2 Answers 2

0

See this article, which says:

Install Infrastructure Update http://support.microsoft.com/kb/953749/ and pay close attention to one small line written in the notes part of the knowledgebase article:

To prevent the declarative workflows from impersonating the system account, the workflows will now impersonate the user who created the workflow association.

This basically means that you should create a special account not SHAREPOINT\SYSTEM, that is a site collection owner on the site collection where the workflow is hosted, open the workflow in SharePoint Designer while logged on as this new account and simply save the workflow without modifying anything.

It will effectively change the account that associated the workflow, which will allow it to start.

you should also run

stsadm -o setproperty -pn declarativeworkflowautostartonemailenabled -pv true

to enable workflows to start using the impersonation scheme

1
  • this solution is for wss 3.0 not sharepoint 2010
    – kadben
    Commented Jun 25, 2012 at 10:37
0

Finally I used an event receiver to start the workflow associated to the task list.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.