0

I'm encountering some problems with UPS. After the installation every user from sharepoint has all fields parametrized (eg.: Department) but if I change them and launch a Sync (full or incremental) my profile data won't change...

Any suggestion? The profile service synch is configured..

If I take a look to the Logs, when I try to access to the field Department i Receive this exception:

An error was encountered while retrieving the user profile.   at Microsoft.Office.Server.UserProfiles.UserProfileCache.GetUserData(UserProfileManager objManager, Nullable`1 recordId, Guid gAcct, String strAcct, Byte[] bSid, String strEmail, Boolean doNotResolveToMasterAccount)     at Microsoft.Office.Server.UserProfiles.UserProfile.RetrieveUser(String strAcct, Guid gAcct, Byte[] bSid, Nullable`1 recordId, Boolean doNotResolveToMasterAccount, Boolean loadFullProfile)     at Microsoft.Office.Server.UserProfiles.UserProfile..ctor(UserProfileManager objManager, String strAcct, Boolean doNotResolveToMasterAccount, Boolean forceUserIsSelf, Boolean loadFullProfile)     at Microsoft.Office.Server.UserProfiles.UserProfileManager.GetUserProfile(String strAccountName, Boolean doNotResolveToMasterAcco... 7650f392-b6f2-4496-9533-d3b1e3330cc5

If I Take a look at accounts in manage accounts I see only one account even if I have set every account of my domain to be imported.

Any suggestion? I have the same problem in 2 different installation of sharepoint on the same domain network

0

Disinstalling services and reinstalling it following step by step this guide, I won!

http://www.harbar.net/articles/sp2010ups.aspx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.