I am having an issue with a single Document Library that gives a 404 on all pages.

After trying to recreate a page in this Library I get an error that it already exists. I looked under "All Site Content" I can see that this Library does indeed show that I have items in it. If I try to access any page in this Library, I get a 404.

After doing some research I was reading that it was due to the default view, so I tried creating new views and setting them as the default view but that did not work. I also checked the permissions for the Library and they are inherited from the parent site and all appear to be correct with proper access to user accounts.

What else could this issue be?

  • Fire up Fiddler and see if it provides more insight into exactly what is going on
    – Dave Wise
    Jun 18, 2012 at 21:00
  • What am I looking for with Fiddler? It's just telling me that the page resulted in a 404.
    – gpresland
    Jun 19, 2012 at 12:31
  • Is the actual URL that is being request on that 404 the one that you are expecting to be requested? (i.e. is there a redirect in the mix)
    – Dave Wise
    Jun 19, 2012 at 14:06
  • No there is no redirection taking place.
    – gpresland
    Jun 19, 2012 at 14:24

2 Answers 2


My issue was that under Central Administration > Web Applications > Managed Paths I had a path that had the same name as my Library. I simply deleted this managed path and everything worked.


Each library or list have a root SPFolder. If you use some specific words in the name of SPFolder, it's created, but you can't access it correctly. For example, I have same issue with folder name conatined "files" substring. SPFolder was created, but property SPFolder.Exist is always false. Your issue looks similar.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.