4

When i create a sandbox solution, and i want to use resources in my code, i use sattelite assemblies.

But in my masterpage it seems not to work, i get following error:

Parser Error Message: The resource object with key 'sps_contactus_link' was not found.

If i use

NavigateURL="<% $Resources:Resources.Properties, sps_sitemap_focusareas_link %>"

then i get the following error:

Could not find any resources appropriate for the specified culture or the neutral culture.  Make sure "Resources.Resources.Properties.resources" was correctly embedded or linked into assembly "App_GlobalResources" at compile time, or that all the satellite assemblies required are loadable and fully signed. 

But if i use

NavigateURL="<% $Resources:Properties, sps_sitemap_focusareas_link %>"

then i get the following error:

The resource object with key 'sps_sitemap_focusareas_link' was not found.
1
  • Do an IIsreset and the values will get reflected
    – user14661
    Commented Feb 5, 2013 at 10:08

1 Answer 1

1

are you using embedded resources and accessing them in Sandbox solution likely?

See more details: http://blog.sharepointbits.com/2011/03/localization-in-sharepoint-2010-sandbox.html

1
  • I work like that way, and that works fine in my C# code; but when I want to use it in a master page I get the error.
    – Davy
    Commented Jun 13, 2012 at 10:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.