During usage yesterday my SharePoint services locked up the entire server and forced me to end process SharePoint tasks and stop SharePoint services. The problem was attributed to Office Web Apps, so I uninstalled it. After all this, I find IIS has deleted all the SharePoint sites, leaving a NULL entry in their place. I had to do a manual restore of the IIS configuration files to bring them back. After this, SharePoint pages weren't loading because it was asking for a bunch of DLLs that Office Web Apps has, so I reinstalled Office Web Apps. I was still unable to view the SharePoint site, so I did a restore of the SharePoint database.

Now I am stuck at:

Cannot connect to the configuration database.

When I try to load the SharePoint site.

When I try to run SharePoint Central Administration I get:

Cannot browse to the Sharepoint Central Administration Web Application because a sharepoint central Administration Web application has not been created Yet. To create one, use the sharepoint configuration wizard.

When I run Products Configuration Wizard I and try to connect to an existing server\SQLInstance, it tells me it can't find it. If I load Microsoft SQL Server Management Studio, I can see and connect to the instance. In SQL Server Management Studio however, I cannot view the table of the databases, and the only logins are BUILTIN\Users and sa (which sa is disabled). The administrative account cannot make any changes to the logins or databases even though it is a member of the WSS_ADMIN_WPG group.

I am looking for direction as to where to go from here.

4 Answers 4


First of all, uninstalling Office Web Apps will uninstall SharePoint (there tons of known issues with this - just Bing it).

Secondly since you just uninstalled SharePoint, was it a standalone installation (that set up SQL and everything for you) of farm installation?

You should reinstall your whole server/farm and then mount back the content databases. (that what I would have been doing, instead of trying to "fix it")

  • It was a standalone installation.
    – gpresland
    Jun 6, 2012 at 14:41
  • I uninstalled SharePoint then Office Web Apps. I reinstalled SharePoint and have full access to the SQL instance now. I am setting up a new server farm since now since connecting to an existing requires a passphrase, which I believe SBS2011 did for me thus I do not have that passphrase. So in creating a new server farm I try to go overtop of my existing SQL instance and it fails telling me the databases "must be empty". Should I create a new SQL instance to install the farm? If so, what databases/table to I move to the new SQL instance after?
    – gpresland
    Jun 6, 2012 at 18:46
  • since you're setting up a new farm its pretty safe to remove all old databases, except the content databases (normally named WSS_Content_???) Jun 7, 2012 at 5:46
  • There doesn't seem to be a way to install SharePoint on SBS 2011 without manually installing SharePoint, SQL Instance, configuring IIS, and configuring all the accounts in AD/IIS/SQL. The manual setup of these 4 systems is turning into a nightmare in which none of them want to work together. As I recall, the Companyweb/SharePoint on SBS 2011 comes presetup and installed and thus you never have the passwords for the accounts. Is there anyway to rerun this factory setup?
    – gpresland
    Jun 8, 2012 at 19:43

These two approaches may be helpful - get an assessment of your SP Farm using a tool like SPSFarmReport (2010SPSFR.exe) which would report on your SP Farm installation and deployment. Second, use PSCONFIG command-line utility which can help reconfigure the SP Configuration database.

If the above two approaches provide no insights nor fixes, then I am afraid a reinstallation with a reattachment of the SP databases may be the only solution.


I don't see this as a SharePoint issue. It is strictly a sql server connectivity/security issue. If you are having issues browsing the database tables through SSMS, ensure your account has proper access (db_owner, or read write). If you cannot see the config/content database(s) at all, ensure the dbs are attached.

If you go to Start->Admin Tools-> ODBC Sources, and attempt to set up a ODBC source to the SQL Server instance, it will be a good test for general application connectivity. good luck.

  • I can connect to the database using the administrative account, but it appears I have read only access. Like I said, there's no other accounts setup for the database, which I guess means that when I uninstall Office Web Apps it deleted the spfarm account that write access to the DB. Now there are no accounts with write access to the DB.
    – gpresland
    Jun 6, 2012 at 16:36
  • I would be surprised if uninstalling the Office Web Apps would delete SQL Server accounts. My suggestion would be to create a new service account (or temporarily use the admin account) and assign it read write access to the content and config dbs. Then, try and connect to the config db via the wizard using that service account. You can change account with which you connect to the db, later in CA.
    – 1c1cle
    Jun 6, 2012 at 18:52
  • I have full access to the SQL instance now. It was that the administrative account couldn't see the other security accounts as it was not a sysadmin. The administrative account is now a sysadmin and can see/do anything. As per connecting to the SQL instance with the SharePoint Product Configuration Wizard, it is requiring a passphrase to connect which I did not setup, and therefore do not know.
    – gpresland
    Jun 6, 2012 at 19:10
  • Great. Moving along. About the passphrase: yes, the person who set up the farm created the passphrase. if you have local admin access, you can reset the passphrase using the SharePoint Powershell console. the powershell statements to execute can be found by googling 'sharepoint passphrase'. first search result should do the trick. good luck.
    – 1c1cle
    Jun 7, 2012 at 13:41
  • I can't reset the passphrase because the farm was destroyed with the uninstallation of Office Web Apps, since it was a standalone install. I took my backups of the databases and am in the processes of manually setting everything up again from scratch. As Wictor Wilen mentioned above, I will simply swap out the WSS_Content database afterwards to hopefully restore my old SharePoint content.
    – gpresland
    Jun 7, 2012 at 14:08

This blog post helped me i followed and then mine worked http://heresjaken.com/sharepoint-cannot-connect-to-configuration-database-error-after-installing-kb-update-on-sbs-server-2008/


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.