Hi I'm working on a workflow and I'm trying to set a field in the current item to a value calculated. Im trying to do this:

Calculate Current Item:GP Instance Run Count plus 1 (output to Variable: temp)
then Set GP Instance Run Count to Variable: temp

But in the drop down menu of the set action the field GP Instance Run Count doesn't show up. This is not the first time SPD does this. It sometimes hides random fields, and I don't know what to do...

Screenshot of SPD problem

You can see int the image above that I was able to access GP Instance Run Count in the previous action

  • How is GP Instance Run Count defined? Commented Jun 5, 2012 at 8:52
  • I guess you took step "Set Field in Current Item This action is initially displayed in a workflow step as Set filed to value Use the action to set a field in the current item to a value." Because: The Set Field in Current Item action is not available when you are working in a site workflow. (Source: office.microsoft.com/en-us/sharepoint-designer-help/…) Commented Jun 5, 2012 at 8:54
  • Maybe you should use Update item in list ? Commented Jun 5, 2012 at 8:55
  • GP... was declared as a number site column and then added to a new content type. @Shegit I'm sorry but I did not understand your first comment, even using Update item in list doesn't show the GP... field Commented Jun 5, 2012 at 10:10
  • I see that a site workflow might not work on a list, so there could be no effect because of using in a site workflow Commented Jun 5, 2012 at 11:58

8 Answers 8


I did my new hire form in Infopath using the same book and ran into the same issue. Not sure if OP is using Infopath but if anyone else is, this was the fix for me. The column wasn't editable so the workflow couldn't set field to that column.

Set the gpinstanceruncount as a number field in infopath
Add it in property promotion
Go to publish (not quick publish)
Go through the wizard and get to the promoted properties page
Find the promoted field (gpinstanceruncount) and hit modify (or double click)
Check the box "Allow users to edit data"
This column is now editable and the workflow can write the 1 value in there

Hope this helps someone!


I had the same issue and the only way I was able to fix was to make sure the site column GP Instance Run Count was added to the list. I then exited out of Designer and reconnected again. GP Instance Run Count was in the list then.


One thing that always work for me though is to set the number of decimal places, to say 0 instead of automatic and specify a default value, e.g. 0.
For existing site columns in site content types, you'll have to remove and add again for it to reflect.

  • to say I actually searched in hope of a better solution...
    – keni
    Commented Oct 27, 2012 at 14:40

This sounds like an example from the book Professional Workflow in SharePoint 2010 by Galvin and Ethirajulu (Wrox, 2012).

The authors instruct the reader to set the GP Instance Run Count field to be hidden as it is a Technical site column. This, I've found, makes the field no longer available for the Set Field in Current Item Action in the workflow.

To work around this, I had to make the Technical fields visible and optional and instead rely on the views to hide them. What to do about the forms, however, is still a mystery.

  • For the forms, I wound up using Javascript (jQuery to be specific) in order to hide the technical fields when the forms load. I reorder the columns to place the technical columns at the bottom so they appear below the fold so that once they are hidden, the user experience is hardly affected.
    – Draghon
    Commented Sep 26, 2013 at 12:16

If you look at "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\TEMPLATE\1033\Workflow\WSS.ACTIONS" you see that:

The Do Calculation action specifies that parameter 1 has DesignerType="Textbox" which allows almost anything.

The Set Field in Current Item action specifies that parameter 1 has DesignerType="WritableFieldNames" which allows "List that contains all fields in the list or document library with which the workflow is associated that are not read-only, or a list of all document libraries on the current site that are not read-only, depending on the context."

So apparently SharePoint designer has figured out that "GP Instance Run Count" is read-only.

  • I see no apparent reason why "GP Instance Run Count" should be readonly. How should I check if it is, and then how do I change it to writeable Commented Jun 5, 2012 at 10:10

It looks like I've found the problem. The column of GP Instance Run Count was in the content type, but not in the list I'm working on which uses that content type

  • And how did you solve it? I mean, did you find a way (and which) to use it? Commented Jun 5, 2012 at 12:01
  • I simply added the site column to the list Commented Jun 6, 2012 at 10:53
  • I've got the same problem as described above. I tried to add GP Instance Run Count to the list and it says it is already there. But it doesn't show up as a column in the list. Any ideas what could be causing that? I know it is associated to a different site column group, but I don't think that shouldn't matter. But I really don't know. Any help would be appreciated.
    – user11293
    Commented Oct 11, 2012 at 18:37

I got the same issue. In my case I was using web site content types which had hidden fields. Due to that the column did not syncronized down to the list properly. I ended up re-creating the content type, left all fields to "optional", created the workflow and after that I hid the columns in the list -not on web site level.


I think the way to resolve this is to leave the field associated with the Site Content Type as Optional. Then change the field associated with the inheriting List Content Type to Hidden.

This way the field will be hidden on the form, but show up in the workflow.

It makes sense if you think about it. The scope of the workflow is for the entire site, but fields can be hidden both at the site level or the list level.

Hope this makes sense.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.