A few days ago my sharepoint instance started to bug out.

  • Unable to deploy from VS2010 Error message

    Error occurred in deployment step 'Recycle IIS Application Pool': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
  • Every minute an error was inserted into event log (Error below)

    Application Server job failed for service instance Microsoft.Office.Server.Search.Administration.SearchServiceInstance (02845955-1908-4ed1-a503-efa56e093ee2).
    Reason: The specified module could not be found. (Exception from HRESULT: 0x8007007E)
    Technical Support Details:
    System.IO.FileNotFoundException: The specified module could not be found (Exception from HRESULT: 0x8007007E) 
    at Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
    at Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedSe rviceInstances(Boolean isAdministrationServiceJob)

EDIT. The above error inserted in the event log, seems to be the root cause. The error i get when trying to deploy is because the IIS application pool is missing some module. Probably some search module "Application Server job failed for service instance"

When i try to reinstall sharepoint 2010, i get an error saying that im "Missing office components"

Very annoying, as it has been working for a month, and i have no idea what changed. I tried running the configuration wizard just after it failed, but the above error shows up and the configuration fails.

Today i tried reinstalling the whole thing, including the prerequisits. And it installed with no errors. But when i try to run the configuration wizard, it fails with the exact same error as before the reinstall.

After looking at the errors in the event log, it seems that the error just started out of nowhere. My OS is windows 7 professional.

Has anyone got any clue what module it is that i'm missing? Or just how to get rid of the error, as it seems it is some kind of search thingy. And as this is my development environment, i don't care about search.

Thanks in advance.

  • It seems that the issue is that WMI is corrupt. which is some kind of built in module in windows. Doing a complete format this afternoon. (A windows repair should also do the trick)
    – Moulde
    Commented Jun 4, 2012 at 10:57

1 Answer 1


WMI was corrupted, and fixing the issue required a complete re-install. Repairing unfortunately didn't do the trick for me, but from what i read, some people fixed the issue just by repairing windows. So definitely try that before formatting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.