3

I have configured forms authentication on a web application. FBA users can be used to access the website but NTLM users not getting resolved. Because of this I cannot use AD users in SharePoint.

I need to use both FBA and active directory users in my web application.

Can any of u help me on this.

5
  • What do you mean by "NTLM users not getting resolved?" Do you have both Windows and FBA set up on the same web application, or did you extend the web application to support one of the authentication providers? If both providers are configured on the same web app, do you see the default sign-in page that lets you choose between Windows and Forms Authentication when you click "Sign In?" May 29, 2012 at 20:38
  • Ya.. I have setup both on the same web application and I do have a default sign-in page.
    – Strider
    May 30, 2012 at 3:01
  • I assume you're choosing "Windows" and not "Forms" when you want your AD users to log in? Are you attempting to log in on the SharePoint server itself or from other client machines? Are you seeing any 401 or other errors in the IIS logs from failed AD logins? May 30, 2012 at 10:04
  • ya... I am using windows authentication to signin AD users. I will signin the default sign in page of SharePoint. I did not have 404 error.. but like the user name are not recognised in SharePoint
    – Strider
    May 30, 2012 at 11:38
  • Can you provide a screen shot of your web application authentication providers - particularly the Windows and forms based authentication sections? Please also you share your web.config for this web application? Are you using a single server or multiple? Jan 5, 2014 at 12:46

2 Answers 2

1

are you using a custom login page?

I have setup a few web applications using this walk through:

http://blogs.technet.com/b/mahesm/archive/2010/04/07/configure-forms-based-authentication-fba-with-sharepoint-2010.aspx

and it allows authentication for both FBA or AD users, however using the out of the box setup they must indicate if they are using FBA or windows authentication during the authentication process.

3
  • I have configured the fba properly... Only issue is AD users are not shown up... I had tried the same config in another system where it works fine... I think it may be because Service Packs are not installed in my machine.
    – Strider
    May 29, 2012 at 17:03
  • What do you use to login to central admin? your FBA account or your AD account? May 31, 2012 at 17:04
  • Central admin is AD account.
    – Strider
    May 31, 2012 at 17:28
0

have you checked that the authentication providers for each zone are setup correctly? (central admin).. I don't have a SharePoint site in front of me but here is what I would check... A- has the server lost connection to AD? B- authentication providers setup correctly for the zone which the alternate access mapping is configured on. C- that you have extended web app from windows auth to forms auth rather than the other way round

If its a dev environment, you can always try a reboot of the box :)

Let me know if this helps

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.